summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 09:10:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 09:48:10 +0100
commitb00930f1455b8bc825ea666c8c6a8747ac8b9d56 (patch)
treede1a464d4a220f616e6e7a7ede02d5b1bb1f58ec /dev-python/rst-linker
parentdev-python/boto3: Bump to 1.17.25 (diff)
downloadgentoo-b00930f1455b8bc825ea666c8c6a8747ac8b9d56.tar.gz
gentoo-b00930f1455b8bc825ea666c8c6a8747ac8b9d56.tar.bz2
gentoo-b00930f1455b8bc825ea666c8c6a8747ac8b9d56.zip
dev-python/rst-linker: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-2.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index f2139462b816..97384bab14bd 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1 +1,2 @@
DIST rst.linker-2.1.1.tar.gz 13492 BLAKE2B 0f53f3110c4a54e7eb36787ed08f81d0ce551174251203b7184ccbcc0153ee450e8e8927e8989b572b929219b1002019f49167482d59956ad96a54360317f998 SHA512 c49e6b3de41636184f75941d8fa258c2dad3d13a7d82b6221a10f583ada228a96f56abefce7840f93cbae8512332b69430601961cc396f3917b912e369b2b1b9
+DIST rst.linker-2.2.0.tar.gz 14339 BLAKE2B fedeb8deea3ba3dc1f084a08476d2117787dd33c3ff2cd4c7881283e3c3e6813ffc143373812adfb4e578d21034d2c287a5af2b1e3dc9ae2f087cae9364d2ce3 SHA512 3e51103eb5111e1dd6e4e6f8c546a366eeb669d27b050de41a0580ac992117c530c322ed7cf31fd26a2f4a872ce8a7a41e801630e9291a6a644befd7272351a1
diff --git a/dev-python/rst-linker/rst-linker-2.2.0.ebuild b/dev-python/rst-linker/rst-linker-2.2.0.ebuild
new file mode 100644
index 000000000000..e32e43d93ce9
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="https://github.com/jaraco/rst.linker"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs ">=dev-python/jaraco-packaging-3.2"
+distutils_enable_tests pytest