summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-10 11:33:34 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-10 11:33:34 +0300
commitaa525ecc052be76963def5685c8b9079024a3973 (patch)
treeb8173386832318285028f06ac4addbecc3c310e5 /dev-python/requests
parentapp-emulation/docker-compose: Drop lower bpundary for requests (diff)
downloadgentoo-aa525ecc052be76963def5685c8b9079024a3973.tar.gz
gentoo-aa525ecc052be76963def5685c8b9079024a3973.tar.bz2
gentoo-aa525ecc052be76963def5685c8b9079024a3973.zip
dev-python/requests: Security cleanup
Closes: https://bugs.gentoo.org/668716 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.18.4-r1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index bfd440a8fc6f..9797fc1d7b84 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1,2 +1 @@
-DIST requests-2.18.4.tar.gz 126224 BLAKE2B 98ab1fe39832673ea7900029da275e031fc85811d6ddb0f37609ec50b18e17d8a04b6cef397bc626ba13da32e16ffa961626879106941d327694d8763dc1efb6 SHA512 5c59bed82ac1094194f04a973b299f7d783264d372abd7a5229295bccc6b2f7a9f082ee4b0dff348e9c22cf68ddbd7cb67f60fd0b7d9eda41c02e40d075e9472
DIST requests-2.21.0.tar.gz 111528 BLAKE2B 7b40f9f572a8efde41c177fb5d1e1eaf29ca60cad0661fa28ac0085f3700348380d619f68c0082f24044d1af82b16d6b1e7d5dd2c2a2329f85fcee7141b1fbf6 SHA512 385e1d80993a21c09e7c4682500ca8c24155962ba41ecd8e73612722b2ff6618b736e827fc48ad1683b0d2bc7a420cfe680f5107860aca52656ef777f1d60104
diff --git a/dev-python/requests/requests-2.18.4-r1.ebuild b/dev-python/requests/requests-2.18.4-r1.ebuild
deleted file mode 100644
index 44453c612cb3..000000000000
--- a/dev-python/requests/requests-2.18.4-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="socks5 +ssl"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-2.7[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.23[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
- )
-"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-#DEPEND+="
-# test? (
-# dev-python/pytest[${PYTHON_USEDEP}]
-# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
-# dev-python/pytest-mock[${PYTHON_USEDEP}]
-# dev-python/pytest-xdist[${PYTHON_USEDEP}]
-# >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
-# )
-#"
-
-python_test() {
- py.test || die
-}