summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-09 16:23:21 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-09 17:35:28 +0200
commit49f2b5caea378028462ab01090ad2241aa8cebe0 (patch)
treef78e6af8fe0007f3e61b7077b8b6ac4d573ccb9d /dev-python/repoze-who
parentdev-python/repoze-who: Enable tests (diff)
downloadgentoo-49f2b5caea378028462ab01090ad2241aa8cebe0.tar.gz
gentoo-49f2b5caea378028462ab01090ad2241aa8cebe0.tar.bz2
gentoo-49f2b5caea378028462ab01090ad2241aa8cebe0.zip
dev-python/repoze-who: Fix namespace support
Diffstat (limited to 'dev-python/repoze-who')
-rw-r--r--dev-python/repoze-who/repoze-who-2.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/repoze-who/repoze-who-2.2-r1.ebuild b/dev-python/repoze-who/repoze-who-2.2-r1.ebuild
new file mode 100644
index 000000000000..f2f3ac568592
--- /dev/null
+++ b/dev-python/repoze-who/repoze-who-2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="repoze.who is an identification and authentication framework for WSGI"
+HOMEPAGE="http://www.repoze.org"
+SRC_URI="mirror://pypi/${PN:0:1}/repoze.who/repoze.who-${PV}.tar.gz"
+S="${WORKDIR}/repoze.who-${PV}"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/namespace-repoze[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install __init__.py files for sub-namespaces
+ python_moduleinto repoze/who
+ python_domodule repoze/who/__init__.py
+
+ python_moduleinto repoze/who/plugins
+ python_domodule repoze/who/plugins/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}