summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 10:19:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 10:31:57 +0100
commit5193cb7a0fb3017e76be9a53829bdccefa6cc794 (patch)
tree50f2d2b44c46a00ba0d50e0ed24e866618057033 /dev-python/reno
parentdev-python/odfpy: Enable py3.11 (diff)
downloadgentoo-5193cb7a0fb3017e76be9a53829bdccefa6cc794.tar.gz
gentoo-5193cb7a0fb3017e76be9a53829bdccefa6cc794.tar.bz2
gentoo-5193cb7a0fb3017e76be9a53829bdccefa6cc794.zip
dev-python/reno: PEP517, py3.11, pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/reno-3.5.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/reno/reno-3.5.0-r1.ebuild b/dev-python/reno/reno-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..af452418d530
--- /dev/null
+++ b/dev-python/reno/reno-3.5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="
+ https://opendev.org/openstack/reno/
+ https://github.com/openstack/reno/
+ https://pypi.org/project/reno/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~s390 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc needs to be built from a git repository
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Some tests need to be run from a git repository
+ rm reno/tests/test_{cache,semver}.py || die
+ distutils-r1_python_prepare_all
+}