summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 21:16:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 21:18:45 +0100
commita72b76eb5f478c7783079e53e3a476f0fdd1cbed (patch)
tree582856b91bafa8d3fb4de287d4e5ae0e52589165 /dev-python/redis-py
parentdev-python/ruamel-yaml: Remove old (diff)
downloadgentoo-a72b76eb5f478c7783079e53e3a476f0fdd1cbed.tar.gz
gentoo-a72b76eb5f478c7783079e53e3a476f0fdd1cbed.tar.bz2
gentoo-a72b76eb5f478c7783079e53e3a476f0fdd1cbed.zip
dev-python/redis-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-4.0.2.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index 6c8d91b6828a..8d2196ffa355 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,3 +1,2 @@
-DIST redis-py-4.0.2.tar.gz 2262717 BLAKE2B 7db99843b4ee354b0841de1cacca001901b0614868e6cd545edb0f3705b7dc7d7a0ee755e2184ec1fb080a845a2f193ff5ab5a4dd99006eed6b9a1c89fbee131 SHA512 3f73ddd2ceb551fa447cfb4ecdc1d393957bbfd8c184ae3d357f9f47fff860f1c4684ec0fc3cb85fea530454456c17a98a2a56e592bef4cd9ad17bb405c1a0f7
DIST redis-py-4.1.0.tar.gz 2346542 BLAKE2B 3d59f904f376df7bca14dcd7bc8547d7a7b41b8d934a50ade6dbf5e74f3da8deef59b3b7cf683fe3c7389859f76fe1d3307f91b52250da945f91b90c629640ab SHA512 85cd09570f4faf34a735befd0677aa8ca2cb0d62b0285c4c040380c2440f2774e47762ec4219381294465343353a15804b96f06b4d6eefa7159a224eb9e72001
DIST redis-py-4.1.1.tar.gz 2349319 BLAKE2B adebda19239e1fd4cf685c0de7a9b2c2fc4e8f23df0e80f2ecdf5f4b9b8b2698fbab613975bd380ea74dc275710d8ed58ee0720486c079bf554612cb7d8b392e SHA512 a974a910dcbaf75516e311badbe6e019cdce668a6d8cd918503934bb92bf97f7ea373fae32139f89a9eecdb360184ae42d24d742ef8b008e95eae648bd992e64
diff --git a/dev-python/redis-py/redis-py-4.0.2.ebuild b/dev-python/redis-py/redis-py-4.0.2.ebuild
deleted file mode 100644
index fac315489b31..000000000000
--- a/dev-python/redis-py/redis-py-4.0.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/redis/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
-
-RDEPEND="
- dev-python/deprecated[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- )
-
- epytest -k "not redismod"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}