summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/queuelib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/queuelib')
-rw-r--r--dev-python/queuelib/Manifest1
-rw-r--r--dev-python/queuelib/metadata.xml8
-rw-r--r--dev-python/queuelib/queuelib-1.1.1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/queuelib/Manifest b/dev-python/queuelib/Manifest
new file mode 100644
index 000000000000..6ffa4431c315
--- /dev/null
+++ b/dev-python/queuelib/Manifest
@@ -0,0 +1 @@
+DIST queuelib.tar.gz 6969 SHA256 f771790be92a93c49fa6da0cab349d59e481fef784b8230bf9338d9036e90b8e SHA512 54b649d08ca60ed933d862b9d5845af162843f4f077722c78b7c72be4093406cc44182905a2d21235635afc1139974c08c213ccd8a333e72fd94c06adc34497a WHIRLPOOL 808ef3b957315505157fbac019b8ecab729f5c7539edeb289f47af540cc536ca55bcbbf0bd7edab7a105451fdfc9e2d8667409ea09383b7eb4980c22a0bedeea
diff --git a/dev-python/queuelib/metadata.xml b/dev-python/queuelib/metadata.xml
new file mode 100644
index 000000000000..257589dd8ef3
--- /dev/null
+++ b/dev-python/queuelib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">scrapy/queuelib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/queuelib/queuelib-1.1.1.ebuild b/dev-python/queuelib/queuelib-1.1.1.ebuild
new file mode 100644
index 000000000000..9c8c195a094e
--- /dev/null
+++ b/dev-python/queuelib/queuelib-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Collection of persistent (disk-based) queues"
+HOMEPAGE="https://github.com/scrapy/${PN}"
+SRC_URI="https://github.com/scrapy/${PN}/archive/v${PV}.tar.gz -> ${PN}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+S="${WORKDIR}/${PN}"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=""
+
+python_test() {
+ nosetests queuelib/tests/ || die "Tests failed under ${EPYTHON}"
+}