summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-26 07:37:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-26 07:40:36 +0200
commit9ffc2f4e1a06f315752d4752ff419aad052610eb (patch)
tree52e3920df86448b4853e22d75e2d92140e59f70b /dev-python/quart
parentdev-python/sphinx-autoapi: Bump to 3.3.3 (diff)
downloadgentoo-9ffc2f4e1a06f315752d4752ff419aad052610eb.tar.gz
gentoo-9ffc2f4e1a06f315752d4752ff419aad052610eb.tar.bz2
gentoo-9ffc2f4e1a06f315752d4752ff419aad052610eb.zip
dev-python/quart: Bump to 0.19.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quart')
-rw-r--r--dev-python/quart/Manifest1
-rw-r--r--dev-python/quart/quart-0.19.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/quart/Manifest b/dev-python/quart/Manifest
index 21f1c927843d..66330a20f754 100644
--- a/dev-python/quart/Manifest
+++ b/dev-python/quart/Manifest
@@ -1 +1,2 @@
DIST quart-0.19.6.gh.tar.gz 747457 BLAKE2B 2912e8e951ad94e8f86e553ee8fac2d3ea679f71be54ff6638aa36d3d3027b48de47994a2f264b3cee69b483ffe4e153c7ea0080b8f6904a2ebaddce2fbede96 SHA512 2a28a36638052c26265122771936dbe8a12332c8abe177a9addafc71b4a0987c864c26f73160492d6e849a5b0a576346ac24c961c5e461afd11981c45aecbcd7
+DIST quart-0.19.8.gh.tar.gz 747979 BLAKE2B 434c5493f01a1ea0cdd223145f52327229af0fd4ddf5739628847c4f78f1b8d76dcb827370446a50227b1afa96d829a47304efed3d017b405632c15c01034292 SHA512 658384387f064f3d0d9af3f79588ab88d28ed7a0922417cf809d2c0ce2e5d4de3c11649368ed57ba3739f88ac2fb8753be31a2e740d052773129a421a38e2115
diff --git a/dev-python/quart/quart-0.19.8.ebuild b/dev-python/quart/quart-0.19.8.ebuild
new file mode 100644
index 000000000000..c0e007644eaf
--- /dev/null
+++ b/dev-python/quart/quart-0.19.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python ASGI web microframework with the same API as Flask"
+HOMEPAGE="
+ https://github.com/pallets/quart/
+ https://pypi.org/project/Quart/
+"
+# no tests in sdist as of 0.19.4
+SRC_URI="
+ https://github.com/pallets/quart/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.6[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.11.2[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}