summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-22 09:19:41 +0000
committerSam James <sam@gentoo.org>2023-03-22 09:19:53 +0000
commit33c886d64157dcc893e4807492dedb1eb297b80a (patch)
tree8d32e1e2f39b87cfbcce6c7f7aef9cab6da2c14e /dev-python/qiskit-terra
parentdev-python/symengine: fix symengine dep (diff)
downloadgentoo-33c886d64157dcc893e4807492dedb1eb297b80a.tar.gz
gentoo-33c886d64157dcc893e4807492dedb1eb297b80a.tar.bz2
gentoo-33c886d64157dcc893e4807492dedb1eb297b80a.zip
dev-python/qiskit-terra: add 0.23.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/qiskit-terra')
-rw-r--r--dev-python/qiskit-terra/Manifest1
-rw-r--r--dev-python/qiskit-terra/qiskit-terra-0.23.3.ebuild185
2 files changed, 186 insertions, 0 deletions
diff --git a/dev-python/qiskit-terra/Manifest b/dev-python/qiskit-terra/Manifest
index c70b908adbac..52caac3c6b67 100644
--- a/dev-python/qiskit-terra/Manifest
+++ b/dev-python/qiskit-terra/Manifest
@@ -41,6 +41,7 @@ DIST pyo3-ffi-0.18.1.crate 62852 BLAKE2B 86bc534333e05578b1bf890fdd71af685d626ae
DIST pyo3-macros-0.18.1.crate 7174 BLAKE2B 0eb2d106d193cfb14fc8c9cce175458a38bc069f9c232a7bc541e2951bd06ad3dfab483f730ece97a4ca2827ad4dcd0444e77df6a8ff79cc5861c2985d0d2b7a SHA512 baf43c6c5ef8f5fcc91728d693d52453b779de5c48cfdb295449a32ce559c0304e3a93b43bad7b312eee1c44bbe680efc57423d4e38986f3c6eacebf07998609
DIST pyo3-macros-backend-0.18.1.crate 48618 BLAKE2B 8db09610fd6fc95d1979a4065f89611c507ff7e7f72d9cd64590f85f6d8543ee6d234e772c55db88e3624808ad135389f5ff0edfd2eca6ecf1a29ece332c1c2e SHA512 20aed4aa485d6ffc02b0d08aa4c5fc086e73482aedb5ebce155c3f973d0e058902ef806740d483368eb80caac4ccc163516eaf56a027910d71cedc5bc0ee665c
DIST qiskit-terra-0.23.2.gh.tar.gz 9530943 BLAKE2B 72160fc302162b3432aa11e5e063004e8eca7ba4d16320b96b6ba6e5621e7e89fd8d34a129fd6d41548d626aacd6461f084b23471fc126ef9e475afa9540b314 SHA512 92536209dae13c5a0720d3acc7f46f7632bbe3be35330970b6d166853727193388aa0afa613ec15f08a86cd3a55991d7c655342dc6a2987ac49588400e7f759a
+DIST qiskit-terra-0.23.3.gh.tar.gz 9524438 BLAKE2B 9b2c322f2db89e956aaa9a5b939daf38d9d85bb388f337a042f7e7595a021c38228e12c1d0fb2953d4bfbe622776d4d178bfa91821dc14bfcf282cef616f24cd SHA512 d5a92b2274bc14a8f74a8c6aed774d71f01921efd6178b2fdb5f054d7bf5d2db84f25da4d035af730338cb95001d1822336f97b383247fcb8accb629a5bd117d
DIST quote-1.0.21.crate 28030 BLAKE2B 547344ba9272874f5fbb4bd27a69ef5be99823e10e1318afe71971b18f37e9c73d54168f16efb82c53a332e4874c80a82ea951fb2c85fad50cdfe783622b79fc SHA512 0728eb4df7e1f7c4d32ab08c901c2c969db8eb46b03bcec3e4956a4f6b360939d32abc6b6ebd7a31058e8e9b69c3d995a24cb484f93656f05b4ee963be1c74fc
DIST rand-0.8.5.crate 87113 BLAKE2B 516f26bb2a969d0d79e957818133f35d2c0b4d9f1b401098ea23c5b80d27599e842b9298c0c5e46e2a6cb6953857bf8a9fb71ec9366c5ce6708cf17df14f179c SHA512 8b33a8988906ba5e2057a9a84bdd11f867a5536c22f5056eec59ed4ec4e3a6da2fd773da4c0510d343762e5a4ea0f007db4c4a7cef87a47f90e36c1a84d86fb2
DIST rand_chacha-0.3.1.crate 15251 BLAKE2B 645771b2c3e274f085e0837a20306b1d59f6e9032fba8eb38a6d1b30180d15e2f89ffa2a162bf6358da41e030098242d81e71dab4321980d0a4f6ddfc2974ce3 SHA512 8198c580b1b9b0429758ffa49cd8138fa3ce724f0dcf73c767ea7e55611d6a2e4c7cad9950896510def500ce4062b594386c947ac3d89425b4e5c9b04d0b8075
diff --git a/dev-python/qiskit-terra/qiskit-terra-0.23.3.ebuild b/dev-python/qiskit-terra/qiskit-terra-0.23.3.ebuild
new file mode 100644
index 000000000000..4cf75605b2f3
--- /dev/null
+++ b/dev-python/qiskit-terra/qiskit-terra-0.23.3.ebuild
@@ -0,0 +1,185 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ ahash-0.7.6
+ ahash-0.8.0
+ autocfg-1.1.0
+ bitflags-1.3.2
+ cfg-if-1.0.0
+ crossbeam-channel-0.5.6
+ crossbeam-deque-0.8.2
+ crossbeam-epoch-0.9.11
+ crossbeam-utils-0.8.12
+ either-1.8.0
+ fixedbitset-0.4.2
+ getrandom-0.2.8
+ hashbrown-0.11.2
+ hashbrown-0.12.3
+ hermit-abi-0.1.19
+ indexmap-1.7.0
+ indoc-1.0.7
+ libc-0.2.137
+ libm-0.2.5
+ lock_api-0.4.9
+ matrixmultiply-0.3.2
+ memoffset-0.6.5
+ memoffset-0.8.0
+ ndarray-0.15.6
+ num-bigint-0.4.3
+ num-complex-0.4.2
+ num-integer-0.1.45
+ num-traits-0.2.15
+ num_cpus-1.13.1
+ numpy-0.18.0
+ once_cell-1.16.0
+ parking_lot-0.12.1
+ parking_lot_core-0.9.4
+ petgraph-0.6.2
+ ppv-lite86-0.2.16
+ priority-queue-1.2.0
+ proc-macro2-1.0.47
+ pyo3-0.18.1
+ pyo3-build-config-0.18.1
+ pyo3-ffi-0.18.1
+ pyo3-macros-0.18.1
+ pyo3-macros-backend-0.18.1
+ quote-1.0.21
+ rand-0.8.5
+ rand_chacha-0.3.1
+ rand_core-0.6.4
+ rand_distr-0.4.3
+ rand_pcg-0.3.1
+ rawpointer-0.2.1
+ rayon-1.6.0
+ rayon-core-1.10.1
+ redox_syscall-0.2.16
+ rustc-hash-1.1.0
+ rustworkx-core-0.12.1
+ scopeguard-1.1.0
+ smallvec-1.10.0
+ syn-1.0.103
+ target-lexicon-0.12.4
+ unicode-ident-1.0.5
+ unindent-0.1.10
+ version_check-0.9.4
+ wasi-0.11.0+wasi-snapshot-preview1
+ windows-sys-0.42.0
+ windows_aarch64_gnullvm-0.42.0
+ windows_aarch64_msvc-0.42.0
+ windows_i686_gnu-0.42.0
+ windows_i686_msvc-0.42.0
+ windows_x86_64_gnu-0.42.0
+ windows_x86_64_gnullvm-0.42.0
+ windows_x86_64_msvc-0.42.0
+"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cargo distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Terra is the foundation on which Qiskit is built"
+HOMEPAGE="
+ https://github.com/Qiskit/qiskit-terra/
+ https://pypi.org/project/qiskit-terra/
+"
+SRC_URI="
+ https://github.com/Qiskit/qiskit-terra/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ $(cargo_crate_uris)
+"
+
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 MIT
+ Unicode-DFS-2016
+ || ( LGPL-3 MPL-2.0 )
+"
+SLOT="0"
+IUSE="+visualization"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/rustworkx-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.10[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.3[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-constraint-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/symengine-0.8[${PYTHON_USEDEP}]
+ visualization? (
+ >=dev-python/matplotlib-3.3[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.3.0[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pylatexenc-1.4[${PYTHON_USEDEP}]
+ >=dev-python/seaborn-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/cython-0.27.1[${PYTHON_USEDEP}]
+ test? (
+ app-text/poppler[png]
+ >=dev-python/ddt-1.4.4[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.24.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/qiskit-aer[${PYTHON_USEDEP}]
+ >=sci-libs/scikit-learn-0.20.0[${PYTHON_USEDEP}]
+ )
+"
+
+# Files built without CFLAGS/LDFLAGS, acceptable for rust
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/qiskit/_accelerate.*.so"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/python/transpiler/test_unitary_synthesis_plugin.py::TestUnitarySynthesisPlugin
+ test/python/transpiler/test_unitary_synthesis.py::TestUnitarySynthesis::test_two_qubit_synthesis_not_pulse_optimal
+
+ # TestOptions::test_copy - TypeError: argument of type 'Options' is not iterable
+ test/python/providers/test_options.py::TestOptions::test_copy
+
+ # DeprecationWarning: Deprecated call to `pkg_resources.declare_namespace('mpl_toolkits')`.
+ test/python/test_version.py::TestVersion::test_qiskit_version
+
+ # AssertionError: DeprecationWarning not triggered
+ test/python/pulse/test_block.py::TestBlockOperation::test_execute_block
+
+ # AssertionError: Lists differ: [] != ['INFO:LocalLogger:bound_pass_manager', 'INFO:LocalLogger:bound_pass_manager']
+ test/python/primitives/test_backend_estimator.py::TestBackendEstimator::test_bound_pass_manager
+ test/python/primitives/test_backend_sampler.py::TestBackendSampler::test_bound_pass_manager
+
+ # Hangs
+ # Broken by https://github.com/Qiskit/qiskit-terra/pull/8952?
+ test/python/compiler/test_transpiler.py::TestTranspileParallel::test_parallel_dispatch_4_3
+ test/python/compiler/test_transpiler.py::TestTranspileParallel::test_parallel_with_target_4_3
+ )
+
+ local EPYTEST_IGNORE=(
+ # TODO, also apparently slow
+ test/randomized/test_transpiler_equivalence.py
+ )
+
+ rm -rf qiskit || die
+ # Run the Python test suite rather than everything under test/ which
+ # includes the 'randomized' suite. Upstream run that in a separate CI job.
+ # Note: use -p timeout --timeout 500 if debugging hanging tests.
+ epytest -p xdist -n "$(makeopts_jobs)" test/python
+}
+
+pkg_postinst() {
+ optfeature "qiskit.circuit.classicalfunction support" dev-python/tweedledum
+}