summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-10 16:44:01 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-10 17:15:33 +0100
commit8a767c366630e6c4ae1b311544779ab2d390926c (patch)
treea5cd7d266440daa2eea926fd4cea0f9a8a984b3d /dev-python/pytools
parentx11-misc/cbatticon: Version bump. (diff)
downloadgentoo-8a767c366630e6c4ae1b311544779ab2d390926c.tar.gz
gentoo-8a767c366630e6c4ae1b311544779ab2d390926c.tar.bz2
gentoo-8a767c366630e6c4ae1b311544779ab2d390926c.zip
dev-python/pytools: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2016.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 5588be367c0b..3d66242ecf62 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1 +1,2 @@
DIST pytools-2014.3.5.tar.gz 47522 SHA256 62a77a3c1865d5254ce212473da2af04f43d82eb0020ae9a009f97408e74968e SHA512 94d2b51cdd87dd11263fdc7d04040979240dea0e0090da0ff325112df9770aacb0849e20812b90f807024ad3815313bc344307a30add8f6795a70e7ebd6adfaa WHIRLPOOL bc3b4c118627d790a1d5bf07f1a4f9e5a4a76a1b38d43b9e6cd3130b8f8415a87807fef4b82ebda778a255e7ed71616f7c8e515fd20f1dad56bdac28023247bf
+DIST pytools-2016.1.tar.gz 47498 SHA256 084feeb68171fc36ddb40f27c4ad5b60d3596716a5f3ad3523257a0d27a351cc SHA512 5492b8b78b6fd00f190d97f3be82c3e807a8e73661888f3b70fc26c5825544f3a76f94c76149b825d77557a74aee2d956231193a9f8056cd433e108556af61df WHIRLPOOL 7c89f0ff132af7782e4738475e493513251c8f18b859b93c57e178a3991e8cd342fa07596e5b049f8707c489e9c3fb9ca2bf0dd0fb274cf0ded68632bf6aee54
diff --git a/dev-python/pytools/pytools-2016.1.ebuild b/dev-python/pytools/pytools-2016.1.ebuild
new file mode 100644
index 000000000000..23181ace0ef3
--- /dev/null
+++ b/dev-python/pytools/pytools-2016.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of tools missing from the Python standard library"
+HOMEPAGE="http://mathema.tician.de/software/pytools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}