summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-15 05:48:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-15 05:59:17 +0100
commit12652d455e0c166597b081ebc30782b8224762d9 (patch)
treef6a634e13dbcad16aa8050501d410ba9e3fc319b /dev-python/python3-discogs-client
parentdev-python/cmd2: Bump to 2.5.6 (diff)
downloadgentoo-12652d455e0c166597b081ebc30782b8224762d9.tar.gz
gentoo-12652d455e0c166597b081ebc30782b8224762d9.tar.bz2
gentoo-12652d455e0c166597b081ebc30782b8224762d9.zip
dev-python/python3-discogs-client: Bump to 2.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python3-discogs-client')
-rw-r--r--dev-python/python3-discogs-client/Manifest1
-rw-r--r--dev-python/python3-discogs-client/python3-discogs-client-2.7.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python3-discogs-client/Manifest b/dev-python/python3-discogs-client/Manifest
index e6152af550ab..15c983f355de 100644
--- a/dev-python/python3-discogs-client/Manifest
+++ b/dev-python/python3-discogs-client/Manifest
@@ -1 +1,2 @@
DIST python3-discogs-client-2.7.tar.gz 36551 BLAKE2B f27fbf17afd7c0f6bb3619a4d0a7922f0a2192b34cddf72cb82f5580d81512d6450aa2464ab5e3746262ccdf66bf3411bd63ed121f69021bed06319bcc171de3 SHA512 7bb43429d6ceb3bbf892b6a65d4d93f0a9ec1bb3535b62169d7e1e4ff0e5032963b2ad5753e381745559efd21ed9e875bfbe3f5260e26f7df5f4a344bedded4a
+DIST python3_discogs_client-2.7.1.tar.gz 36930 BLAKE2B f0e6071759e8e14f4e78fc0cd15fe4643b1984be622e9fdbf28bda11699d4f7d829eaa7aee005c888e556b6c994585b1a5f2c12351a995f2937af87c360f5292 SHA512 4b9ca0fb1498319f814b88f2df6a1bd3d7c02f44bea8a13aa6b640d3d87def825dcc79181afddb173fedb7448f99a8f4a244915ebfaf26dd2411db8d151b054c
diff --git a/dev-python/python3-discogs-client/python3-discogs-client-2.7.1.ebuild b/dev-python/python3-discogs-client/python3-discogs-client-2.7.1.ebuild
new file mode 100644
index 000000000000..82c74caa91d2
--- /dev/null
+++ b/dev-python/python3-discogs-client/python3-discogs-client-2.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest