summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 17:20:22 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 18:18:48 +0100
commit771397c61b2cd40d3d892a903ab4ebf4e3158b59 (patch)
tree5307836b3e5b63a0bcfcc9299f83375babd47e17 /dev-python/python-socks
parentdev-python/phonenumbers: Remove old (diff)
downloadgentoo-771397c61b2cd40d3d892a903ab4ebf4e3158b59.tar.gz
gentoo-771397c61b2cd40d3d892a903ab4ebf4e3158b59.tar.bz2
gentoo-771397c61b2cd40d3d892a903ab4ebf4e3158b59.zip
dev-python/python-socks: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-1.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 1751c8394142..379ca0da8624 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-1.1.0.gh.tar.gz 1358296 BLAKE2B c599095a7f687ba1bba6f0ddbbc8ef2e680cb6be4e5d2250fad88c3a3273fb2044712045b20c5a358ed9dcbaef07e5133b6d672698d8caf4b978c9e633a5df70 SHA512 e38594815e5f943f810862dfe5d07a802601e41e879f68b4fa70c8087be0387a91e99e1b0578f2819557832b5e53be9773043a9617c72017c41e9377c4f35ef1
+DIST python-socks-1.1.2.gh.tar.gz 29948 BLAKE2B c110cd8d5d055aa30a63cdade10e7e67b0d6f0b1b17e76ff40bfb85563c90e026f0169a7e943d1391d75e20d7dd715ab070a6adf9e1e247eccf906d63c324e66 SHA512 c62259e86e7afeba7ee3ef5cdca104846352137e5d5bfa6f475e2ac38b21fe1766aee6a1fcb6b9f725576613ce3d92663fab3682516b96caa3948a05d89333a7
diff --git a/dev-python/python-socks/python-socks-1.1.2.ebuild b/dev-python/python-socks/python-socks-1.1.2.ebuild
new file mode 100644
index 000000000000..8efe7d9b3616
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests rely on connecting to Internet
+RESTRICT="test"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+#BDEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# dev-python/yarl[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest