summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-lzo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-lzo')
-rw-r--r--dev-python/python-lzo/Manifest1
-rw-r--r--dev-python/python-lzo/files/lzo2compat.patch13
-rw-r--r--dev-python/python-lzo/metadata.xml5
-rw-r--r--dev-python/python-lzo/python-lzo-1.08-r1.ebuild26
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-lzo/Manifest b/dev-python/python-lzo/Manifest
new file mode 100644
index 000000000000..374b3613155f
--- /dev/null
+++ b/dev-python/python-lzo/Manifest
@@ -0,0 +1 @@
+DIST python-lzo-1.08.tar.gz 13046 SHA256 2865afe7b995844bf80af94441d1ccf908b0e3aba3eacf5ba602f23e748476c4 SHA512 94b33e3b0e62b9c8a97147507f4516706d25d62c63ea938f0748e520a3e27760f0e3be142cb3e68aea132ae06759c91b3a4dac8e5010cdfab633e6c8d5904d8c WHIRLPOOL 84bcf130df8341ff145d895bc814b58ec2183c15ffedbc345aa6eb89931f22a9c78899c50b7a054beef9d7ca0b0c4be4e5e407a0ee794ee1830e2c6c9e796a31
diff --git a/dev-python/python-lzo/files/lzo2compat.patch b/dev-python/python-lzo/files/lzo2compat.patch
new file mode 100644
index 000000000000..6ce728753df6
--- /dev/null
+++ b/dev-python/python-lzo/files/lzo2compat.patch
@@ -0,0 +1,13 @@
+--- setup.py
++++ setup.py
+@@ -24,8 +24,8 @@
+ include_dirs.append(os.path.join(CURL_DIR, "include"))
+ extra_objects.append(os.path.join(CURL_DIR, "lzo.lib"))
+ else:
+- libraries = ["lzo"]
+- ##include_dirs.append("/usr/local/include")
++ libraries = ["lzo2"]
++ include_dirs.append("/usr/include/lzo")
+ ##library_dirs.append("/usr/local/lib")
+ ##runtime_library_dirs.append("/usr/local/lib")
+
diff --git a/dev-python/python-lzo/metadata.xml b/dev-python/python-lzo/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/python-lzo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/python-lzo/python-lzo-1.08-r1.ebuild b/dev-python/python-lzo/python-lzo-1.08-r1.ebuild
new file mode 100644
index 000000000000..01540f45a666
--- /dev/null
+++ b/dev-python/python-lzo/python-lzo-1.08-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to lzo"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/LZO-v1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/lzo:2"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/lzo2compat.patch" )
+
+python_test() {
+ "${PYTHON}" tests/test.py || die "tests failed"
+}