summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-24 20:00:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-24 20:22:58 +0300
commit02a3bc5effd6d9253fb2d98c5bbebac941a85866 (patch)
tree187214173db530fd5b6346166658f0aa0fa76cd6 /dev-python/python-engineio
parentsys-apps/portage: add support for recognizing LoongArch ABIs (diff)
downloadgentoo-02a3bc5effd6d9253fb2d98c5bbebac941a85866.tar.gz
gentoo-02a3bc5effd6d9253fb2d98c5bbebac941a85866.tar.bz2
gentoo-02a3bc5effd6d9253fb2d98c5bbebac941a85866.zip
dev-python/python-engineio: add 4.3.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.3.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 0e0dfe47960d..4e535310cfac 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,3 +1,4 @@
DIST python-engineio-4.2.1.gh.tar.gz 297657 BLAKE2B 0a634cec9f71a3b8659e5b07cc326fb3d7801c8a834248d6f2ea5a48bcd058f8d0b86c2e43c110ea18ef641e3ace273a2ebd20f350aec9360d38ffe0f32f2778 SHA512 f0ea7cb0a34f49d2e3de58dc1038f41cda099fba0033af7020b9ccacd34fbf44fd1613ef14d4d05013dd99a2d35330769e6c3d2f532556fd39262229e40714f6
DIST python-engineio-4.3.0.gh.tar.gz 299122 BLAKE2B 929b16650aaf4a429e9a1353a994cc87022644bef48c59aac9c448ec32533a7a7360413143159809042915f69c4f0ae0c2a13e5fe2d61b729c09890508107948 SHA512 c34688f1dcaf4a1a02dea03d2746b0b0e089387d4ac55024e783ee2dbafb59ac43437138747b63b0710425601b27e1a10c56df7c57c1ed16ab2f812a773c8ec4
DIST python-engineio-4.3.1.gh.tar.gz 299321 BLAKE2B a5234a12ad4434e0793154569f4c3f7d3c416d6334acf6af6de03336861797a42d6930350944a4ed6cca089daaad731b209878b08c61b29a97793afbcea473ac SHA512 6e00134191ff39e3e2f3f8cd933562be8ee9db1512f6b7d3cc2d52283ee2ea329d942edcde0bbfdfed71348d96c62067c423d666ad32a789eab760b583fc75af
+DIST python-engineio-4.3.2.gh.tar.gz 299722 BLAKE2B 87dece98d72b7b0384e3b9d57062a3eaa7aeb80ac3f2f685d50b8816e122398ffd54da1f4b99a90a1f535e2d0f0d282167a682de022373e6108f7e91f8689aa1 SHA512 59933a0093167042a3873ba1561d2859359a5ad160f6b7b5c19478b1f73d1bd068779942c8bfc44dd5a8d9f155359571298b960bcd217aab341bdfec35bc5b28
diff --git a/dev-python/python-engineio/python-engineio-4.3.2.ebuild b/dev-python/python-engineio/python-engineio-4.3.2.ebuild
new file mode 100644
index 000000000000..84f719997949
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest