summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-15 22:45:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-15 22:45:12 +0200
commited042b6fd73f8b2f6a7f1cc1f44274e95244b648 (patch)
tree80aa4efcf1be90857cb66db7bef8df7d549d72ad /dev-python/pytest-subtests
parentdev-python/simpleeval: add 0.9.12 (diff)
downloadgentoo-ed042b6fd73f8b2f6a7f1cc1f44274e95244b648.tar.gz
gentoo-ed042b6fd73f8b2f6a7f1cc1f44274e95244b648.tar.bz2
gentoo-ed042b6fd73f8b2f6a7f1cc1f44274e95244b648.zip
dev-python/pytest-subtests: add 0.6.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 1a5f8a40e75a..b9caba38ac9b 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1 +1,2 @@
DIST pytest-subtests-0.5.0.tar.gz 9793 BLAKE2B c671eb14189c0fd34180a636592b20c9e2b4225c5faf3b702103164e60bdbac4c9644e464f1e0c783da3da1263f7b841ea7a4149bcbf1de23325a8ef3ce5c030 SHA512 e3d7e90c3ab66950eb80d25049bc6f6f75b08b3da5ce0de5f3fc55d6a176a8d1fdcb19a19f7d9d137aeadcc82b214550474f76d5611bc5592ca649ddd8257a2a
+DIST pytest-subtests-0.6.0.gh.tar.gz 9698 BLAKE2B 7b8f8c78ca503d107466d1ff34830aa08c3c5ec9b0f9e962b0e61472bf4f7413eb7e71db5768d898d476eb186a5a14c6703f14a990eb57c8664153a4ac384678 SHA512 9b4fa2e1957388f0e61a13a3cce95976fb5fdea64def627c5a1bf75049a0272e82f19ed9aa117bac0d02c6fd8832f22e7cfe409694ea81920def49742142eb93
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
new file mode 100644
index 000000000000..61159d2864ef
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+
+ distutils_install_for_testing
+ epytest
+}