summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 22:15:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:17 +0100
commit45a26408b7ec06fe562247403b9483a06fd0c005 (patch)
tree8fac6e702a4836c877a06d3ed97090be059ac8da /dev-python/pytest-subtests
parentdev-python/python-dotenv: Remove old (diff)
downloadgentoo-45a26408b7ec06fe562247403b9483a06fd0c005.tar.gz
gentoo-45a26408b7ec06fe562247403b9483a06fd0c005.tar.bz2
gentoo-45a26408b7ec06fe562247403b9483a06fd0c005.zip
dev-python/pytest-subtests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 83cf5c338de2..ca91c3210ad4 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,2 +1 @@
-DIST pytest-subtests-0.6.0.gh.tar.gz 9698 BLAKE2B 7b8f8c78ca503d107466d1ff34830aa08c3c5ec9b0f9e962b0e61472bf4f7413eb7e71db5768d898d476eb186a5a14c6703f14a990eb57c8664153a4ac384678 SHA512 9b4fa2e1957388f0e61a13a3cce95976fb5fdea64def627c5a1bf75049a0272e82f19ed9aa117bac0d02c6fd8832f22e7cfe409694ea81920def49742142eb93
DIST pytest-subtests-0.7.0.gh.tar.gz 9714 BLAKE2B 027badb226c6889ed2fb809eb0b3944ef227a804ea58562fe9337f37526a07a41b11cdfd356d8e9a29f9affc9d0702dead59045db9781504c92186ee613ccb1a SHA512 96531a42c06a20cdf3f3665993d3e80d198a60d536246f4dc46df20b56e47f3f6fdce9478351a8922e370435f974e63d565550213fbbeed8487eedc131f46404
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
deleted file mode 100644
index e646136e30ea..000000000000
--- a/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="unittest subTest() support and subtests fixture"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-subtests/
- https://pypi.org/project/pytest-subtests/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-# pytest-xdist is used to test compatibility
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
-
- distutils_install_for_testing
- epytest
-}