summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 20:29:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 20:56:58 +0200
commit0f57cad7ebfd777764dcc0d77941801f6fc01d87 (patch)
treef9fbb4339a917cb24cd0245d028662cb061b95c9 /dev-python/pytest-plus
parentdev-python/sqlglot: Bump to 18.14.0 (diff)
downloadgentoo-0f57cad7ebfd777764dcc0d77941801f6fc01d87.tar.gz
gentoo-0f57cad7ebfd777764dcc0d77941801f6fc01d87.tar.bz2
gentoo-0f57cad7ebfd777764dcc0d77941801f6fc01d87.zip
dev-python/pytest-plus: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index c98f7355f029..06ba69815958 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1 +1,2 @@
DIST pytest-plus-0.4.0.tar.gz 9987 BLAKE2B 11b8f17630601f52ebae11b7a660c8d97b4c9f1699096a376c162952a03b9f1b580ead6ac0b040b15c267eec1123bffe07d128eb00aec7414e996275ebc4c4e3 SHA512 4f4258853280cac8e03c0477763fd588d2b3cf11e7746d2b8e7d3cf5774b845412bc8779d74d232e4b3473470c39753dc788ac09faf8e8b7c9fee22d7164bab7
+DIST pytest-plus-0.5.0.tar.gz 11444 BLAKE2B f42a7d9abc934635414959263a85399ccdf5377eb58790339d816a8ed8b3962ce11f088e0e074163c6ea9498ae07cbb9422586cbfad572200f1fa628f1b9620f SHA512 02417b2b02ec44d505ea8b6a4217c55b88d1b1383ee36c51b4480824816eb57513b63da36b86004a777ebbbca462bdf40ac3b18331010c10ca6d6259c837f705
diff --git a/dev-python/pytest-plus/pytest-plus-0.5.0.ebuild b/dev-python/pytest-plus/pytest-plus-0.5.0.ebuild
new file mode 100644
index 000000000000..f579173ce992
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-plus/
+ https://pypi.org/project/pytest-plus/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest