summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-02-23 19:04:17 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-02-24 01:04:55 +0100
commitb2d614f1f8b5fc6ddb541e2cfe9319cc4b5ed34e (patch)
treeea0856b1815a0b9a103acbaa12d0be97a0f63868 /dev-python/pytest-httpx
parentdev-python/uvicorn: new package, version 0.13.4 (diff)
downloadgentoo-b2d614f1f8b5fc6ddb541e2cfe9319cc4b5ed34e.tar.gz
gentoo-b2d614f1f8b5fc6ddb541e2cfe9319cc4b5ed34e.tar.bz2
gentoo-b2d614f1f8b5fc6ddb541e2cfe9319cc4b5ed34e.zip
dev-python/pytest-httpx: new package, version 0.10.1
New test dependency of dev-python/denonavr. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/metadata.xml13
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
new file mode 100644
index 000000000000..9a409c04b655
--- /dev/null
+++ b/dev-python/pytest-httpx/Manifest
@@ -0,0 +1 @@
+DIST pytest-httpx-0.10.1.tar.gz 21117 BLAKE2B 372ecc8a132f28bf7016ed466c4f6974f51c3c2ab9decd68fd8e3c7a810030db9f169f5ab28662cfed006297ea200d3a157ba220f2156b44be03fbf49edc5415 SHA512 f306e57408924b653d3ab4dd28f266b066f202b98440b31769940bdab0be98d5c48817e22d68e2dcdf82426e26334242591d0ae630aa71812f81dd7866b81e0f
diff --git a/dev-python/pytest-httpx/metadata.xml b/dev-python/pytest-httpx/metadata.xml
new file mode 100644
index 000000000000..18982ca43441
--- /dev/null
+++ b/dev-python/pytest-httpx/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-httpx</remote-id>
+ <remote-id type="github">Colin-b/pytest_httpx</remote-id>
+ <bugs-to>https://github.com/Colin-b/pytest_httpx/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild
new file mode 100644
index 000000000000..b2f04c25ff37
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.16*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest