summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-27 00:21:50 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-27 00:57:48 -0600
commit6407a8ffa6f7ba5242b9719c6bb633c424d826cb (patch)
tree7f9ff88842a6fdf47f023294cf3e1588e9d0acbb /dev-python/pyte
parentnet-analyzer/speedtest-cli: remove old (diff)
downloadgentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.tar.gz
gentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.tar.bz2
gentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.zip
dev-python/pyte: add python3_7 support
Also, bump to EAPI 7 and use github tarball to fix tests. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pyte')
-rw-r--r--dev-python/pyte/Manifest2
-rw-r--r--dev-python/pyte/pyte-0.8.0-r1.ebuild (renamed from dev-python/pyte/pyte-0.8.0.ebuild)16
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/pyte/Manifest b/dev-python/pyte/Manifest
index f9b730c9b521..da77e9b99cca 100644
--- a/dev-python/pyte/Manifest
+++ b/dev-python/pyte/Manifest
@@ -1,2 +1,2 @@
DIST pyte-0.5.2.tar.gz 42719 BLAKE2B 00995c8427ade8a44dbc6dea4bea058431adb1409fbddc90b70ecd3cf4968632d66e4f21140ca5c071ea927208d40ed55606cf2d604f931970f99128c2b2dba8 SHA512 da903b31bb67e60bc8271c162f3429871d0def039cec5f63f07764fce1994236063876eb069a88783a4c7d8b0eac0646549c00f2a51ab8630287d852f05f4b0d
-DIST pyte-0.8.0.tar.gz 50415 BLAKE2B 8e707d8dd598d4b76b281de1481d238448f6ed07daa962647e61e7f5ad62da67a08112db7e21cb3522e5719514975a9b01ec06ff1cf2222590e02d9ff434369e SHA512 b1c23206f32c49ab509ac9bd4e042b043478cae35594c52c8389f5a5ba15cd0895315c42be5a0f2992b3aaa918ae282e43e88e72798a0b600307860f6df06465
+DIST pyte-0.8.0.tar.gz 91320 BLAKE2B b973050912c7d3b67393208a5b17f382705fe78964528e003b71addc12586353a3a9c7eeb68c224dfb945b5f9d3b52823cd254885dd5ac6901be119583a71a2e SHA512 c488fd0a61c1dc34b27e12ed9ba1109bb2c331626c982da06e7540bdd168008cb5106a17c71e60e38c493f2dd9f21ba3cf05118928744dfa192d62e511b4c4e8
diff --git a/dev-python/pyte/pyte-0.8.0.ebuild b/dev-python/pyte/pyte-0.8.0-r1.ebuild
index 7de14fd4a96d..9c9700af2e52 100644
--- a/dev-python/pyte/pyte-0.8.0.ebuild
+++ b/dev-python/pyte/pyte-0.8.0-r1.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
DESCRIPTION="Simple VTXXX-compatible terminal emulator"
HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# use github tarball as pypi is missing test data
+SRC_URI="https://github.com/selectel/pyte/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-3"
@@ -18,15 +20,17 @@ IUSE="test"
RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/pytest-runner[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
python_prepare_all() {
+ # run pytest directly for tests
+ sed -i '/setup_requires=\["pytest-runner"\]/d' setup.py || die
+
distutils-r1_python_prepare_all
}
python_test() {
- esetup.py test --verbose
+ py.test -v || die "tests failed with ${EPYTHON}"
}