summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-03-18 21:51:37 -0400
committerRick Farina <zerochaos@gentoo.org>2020-03-18 22:11:56 -0400
commit375393a5398cd6d48aa2c0ce3b5fd71f0ee3dc82 (patch)
treea2b4c82a2bd640acfff50854257ac48871c453f8 /dev-python/pyscard
parentdev-libs/libreport: Version bump to 2.12.0 (diff)
downloadgentoo-375393a5398cd6d48aa2c0ce3b5fd71f0ee3dc82.tar.gz
gentoo-375393a5398cd6d48aa2c0ce3b5fd71f0ee3dc82.tar.bz2
gentoo-375393a5398cd6d48aa2c0ce3b5fd71f0ee3dc82.zip
dev-python/pyscard: adding python3_{7,8}
tested on 3.7 and tests pass Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-1.9.9.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index c4cd86b9fe58..ced7e8e99edb 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-1.9.7.tar.gz 144692 BLAKE2B 5a842b790e01ff5461c462d6fe2d7763a79725cd1bcb841c1aaa49f2b17decb251446adb908fa8b525b91f418a6df6a76ddf779a67b7e8547211993837aed2bd SHA512 339d6efd5fcaa361e30029e736d4e2e98e05acd701c39574b40960b4bcec4782ca9c1d6927cea0b3641c5e6a137d0b9fbd961b58422a4151cfbdfa067dcd4b4a
+DIST pyscard-1.9.9.tar.gz 145428 BLAKE2B c62d9c2f13d9f19df1b7399509efc9df2baf2da00a9dc0bd9a0b440dcef232beeb0f7da88b12e3fb8ecffeb28f268eaaa04c9d45dc3420a1071835afe7a36c95 SHA512 88c7314c10153f509eb9bf6318e62210c7182e51b531af752a402bf8d05cfa2658cc1a4e7b9385a474038ddfa5a1bfbf1f208fcd9abe02a60161ce7c757c67b2
diff --git a/dev-python/pyscard/pyscard-1.9.9.ebuild b/dev-python/pyscard/pyscard-1.9.9.ebuild
new file mode 100644
index 000000000000..5c90cee6a2f5
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="${PYTHON_DEP}
+ sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${PYTHON_DEP}
+ dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}