summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-13 05:39:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-13 06:11:07 +0100
commit4199e88eb29e41e87403f7f660f01e0251b37cda (patch)
tree328a1ff7ec2a99a37ae58e7f66aeddc4eec267ed /dev-python/pyproject-api
parentdev-python/virtualenv: Bump to 20.21.0 (diff)
downloadgentoo-4199e88eb29e41e87403f7f660f01e0251b37cda.tar.gz
gentoo-4199e88eb29e41e87403f7f660f01e0251b37cda.tar.bz2
gentoo-4199e88eb29e41e87403f7f660f01e0251b37cda.zip
dev-python/pyproject-api: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-api')
-rw-r--r--dev-python/pyproject-api/Manifest1
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index 91b591a6a9d8..8d607289c8ae 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1 +1,2 @@
DIST pyproject-api-1.5.0.gh.tar.gz 22032 BLAKE2B 7e90bacffee70d2a2343f2360f5d0e6794a04a8b8b9be672150e5ac49e1dfabb0673b4c661ddc27f3fffa7bb3d04644e2b1809555987fc0d914a798fac667c8c SHA512 7a68df007e52c685f512fca26d371d1790f2fb9ced381025fe27462088cd4f1488b7edf4de94f6c1df989c4430336789b94d0b3bd634a2f6ec52f14f292b4474
+DIST pyproject_api-1.5.1.tar.gz 22081 BLAKE2B 53ee778b4e04cac2f16ecd054adc7fd86373d6402f80d485fe22457252684f774b6a5df23d08cf6c6b1f96964d6dc1b1cc9014415f3d9105ffbb09421f69a11e SHA512 31936d242861027ea892e86219f430371aae18631c92893cefc8fb8fc02315906857ee57e5412eed62bf584e0bd24cca7ba82471c0ac6a72c71e8e93b8285a3e
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
new file mode 100644
index 000000000000..a161dd7f0dd8
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Python 2 installed
+ tests/test_frontend.py::test_can_build_on_python_2
+)