summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-21 09:07:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-21 09:23:14 +0100
commit37d33c450ba683c7313b026293693b0885d1027e (patch)
treee59c37a0d2c8822dc3b211011cf1f7466315c5c9 /dev-python/pyperclip
parentdev-python/manuel: mark ALLARCHES (diff)
downloadgentoo-37d33c450ba683c7313b026293693b0885d1027e.tar.gz
gentoo-37d33c450ba683c7313b026293693b0885d1027e.tar.bz2
gentoo-37d33c450ba683c7313b026293693b0885d1027e.zip
dev-python/pyperclip: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/Manifest1
-rw-r--r--dev-python/pyperclip/pyperclip-1.8.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pyperclip/Manifest b/dev-python/pyperclip/Manifest
index 1f9477170bce..f764aeb773d0 100644
--- a/dev-python/pyperclip/Manifest
+++ b/dev-python/pyperclip/Manifest
@@ -1 +1,2 @@
DIST pyperclip-1.7.0.tar.gz 15977 BLAKE2B da1473f71bcadcc6dcacdfb6d1a1447b055eb1aa7b31fad76bd3a51245ad9b1e512335f9799d7d416a53b8471ab66c28afa5f9d3f3ee2b39e85d9c239a7e2c79 SHA512 7f22227ea894a236703f61ab950e198fab969fac5713ca8eac6df213183a47a244add88a462b9ddf63ed5bec36af5bc2578949f01ed31e0b63316d1761a935bd
+DIST pyperclip-1.8.2.tar.gz 20920 BLAKE2B d14a7d977b434db5ae3218792ccd73428bab244a6f6a92d3fd7f059ee99f841853b69a8e039a8192a6cca693adc943a93f24835d25471888975b306b7be4a36a SHA512 ade0cdf2bfdbe3ce807a02b64bb1e839afc9955254ddeb3e0fe7c1dd9fd9fddc11f8386a02590690b039045b46e9103e4d094f1bad3e272f532fda4db5ed1c1a
diff --git a/dev-python/pyperclip/pyperclip-1.8.2.ebuild b/dev-python/pyperclip/pyperclip-1.8.2.ebuild
new file mode 100644
index 000000000000..43129c28df83
--- /dev/null
+++ b/dev-python/pyperclip/pyperclip-1.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A cross-platform clipboard module for Python."
+HOMEPAGE="https://github.com/asweigart/pyperclip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ || (
+ (
+ x11-misc/xsel
+ sys-apps/which
+ )
+ (
+ x11-misc/xclip
+ sys-apps/which
+ )
+ (
+ kde-plasma/plasma-workspace
+ sys-apps/which
+ )
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ )
+"
+# test at least one backend
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ # stupid windows
+ find -type f -exec sed -i -e 's:\r$::' {} + || die
+ # klipper is hard to get working, and once we make it work,
+ # it breaks most of the other backends
+ sed -e 's:_executable_exists("klipper"):False:' \
+ -i tests/test_pyperclip.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" tests/test_pyperclip.py -vv ||
+ die "Tests fail on ${EPYTHON}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}