summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pylast
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/metadata.xml25
-rw-r--r--dev-python/pylast/pylast-0.5.11-r1.ebuild18
-rw-r--r--dev-python/pylast/pylast-1.0.0.ebuild18
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
new file mode 100644
index 000000000000..985f630374cf
--- /dev/null
+++ b/dev-python/pylast/Manifest
@@ -0,0 +1,2 @@
+DIST pylast-0.5.11.tar.gz 26146 SHA256 bf35820be35447d55564d36072d40b09ac8a7fd41a6f1a7a9d408f4d0eaefac4 SHA512 4b313156aff927f1ec61a848d1ee4c74fde348e1faef6d8dcf9578b164d65621c85bac3de0288d7aae0147157cc2c01a048d7293c191e9c1ede1197527d987e6 WHIRLPOOL 16f4b0c4b4844997575bb382f62c2b65b69dbf3b3a794e016b84046aefd023e44591e12819171eada7c7d0f88791a85c5d549340d85823d46cd1d1c4d36fd0d9
+DIST pylast-1.0.0.tar.gz 29099 SHA256 948bc9efb2e2785db8c303cc6559358b943538cc45f902838db770b84843d605 SHA512 1d6183596ff994f37722be493e22c65a2c441f5890b539fd9e19d515a5a38afc7017524600903879a8c76b938a52dec6ef4753c0e01dd59bae4e1596962755a0 WHIRLPOOL fd81c5143574f7685383719d76db67b24dbf78d387f3f73846ee2fc2433bf1ea65b1d35961b8f9424fb083f42872bb150e505cbfda93134fcb4509a74d8a8980
diff --git a/dev-python/pylast/metadata.xml b/dev-python/pylast/metadata.xml
new file mode 100644
index 000000000000..4bdf9326e9c3
--- /dev/null
+++ b/dev-python/pylast/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <longdescription lang="en">
+Python interface to last.fm and other api-compatible websites
+
+Features:
+ * Simple public interface.
+ * Access to all the data exposed by the Last.fm webservices.
+ * Scrobbling support.
+ * Full object-oriented design.
+ * Proxy support.
+ * Internal caching support for some webservices calls (disabled by default).
+ * No extra dependencies but python itself.
+ * Support for other API-compatible networks like Libre.fm
+ * Python3-friendly (Starting from 0.5).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pylast</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylast/pylast-0.5.11-r1.ebuild b/dev-python/pylast/pylast-0.5.11-r1.ebuild
new file mode 100644
index 000000000000..a3cd6d748ca7
--- /dev/null
+++ b/dev-python/pylast/pylast-0.5.11-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="http://code.google.com/p/pylast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
diff --git a/dev-python/pylast/pylast-1.0.0.ebuild b/dev-python/pylast/pylast-1.0.0.ebuild
new file mode 100644
index 000000000000..81eb2ec6c48b
--- /dev/null
+++ b/dev-python/pylast/pylast-1.0.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="http://code.google.com/p/pylast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""