summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-18 09:44:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-18 09:48:45 +0100
commit9ca42eaf29070679647899aaefdf0795810f3c5a (patch)
treebba11b092b1bed1abc34494d86e340b2eb2cbebb /dev-python/pyghmi
parentdev-python/python-utils: Bump to 2.6.3 (diff)
downloadgentoo-9ca42eaf29070679647899aaefdf0795810f3c5a.tar.gz
gentoo-9ca42eaf29070679647899aaefdf0795810f3c5a.tar.bz2
gentoo-9ca42eaf29070679647899aaefdf0795810f3c5a.zip
dev-python/pyghmi: Bump to 1.5.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/metadata.xml2
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.31.ebuild31
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 6008e3f6944f..15bc3b9f46fb 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.22.tar.gz 221963 BLAKE2B 6705e904c481ddbb241fc8f8089e6bc9bcc142bfca9aaa518b2293b5dd387113fa4bbb418e748584f69fac5e8d1049d669eb73d24463adaaec3a891cae98f928 SHA512 cc665f8b9f4a0c9c127b9e895ba62e650cdb589f5c9edae6accaa5558f347d31725e8da446fcafb4f71ffadc17121d8b293160413f4a41055cb1720e9fa1ecde
+DIST pyghmi-1.5.31.tar.gz 236574 BLAKE2B 9ee7250bae2d87f552686845ae3056f0f646cd1a383587c195bfcc6dfa476b8582509c909f0008fc6751295e2e4e7d33bf822e8b529d67306fcc85412fc9af22 SHA512 d7c9c05b51780bef9d2b417c1a586f84ec87a9f1ff578ab019bfdc1a462decd907b2634fb1c830d0e369eb97122bfcba62ce79a4386c73c9854cde8f9fdeb65c
diff --git a/dev-python/pyghmi/metadata.xml b/dev-python/pyghmi/metadata.xml
index b98394aee10d..bd120511a5a3 100644
--- a/dev-python/pyghmi/metadata.xml
+++ b/dev-python/pyghmi/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyghmi</remote-id>
- <remote-id type="github">openstack/pyghmi</remote-id>
+ <remote-id type="github">openstack-archive/pyghmi</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyghmi/pyghmi-1.5.31.ebuild b/dev-python/pyghmi/pyghmi-1.5.31.ebuild
new file mode 100644
index 000000000000..f754962e698c
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.31.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack-archive/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest