summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 19:27:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 19:27:43 +0200
commita9b097e7af09b2d3303c981f4aa5f23d17d3d804 (patch)
tree98bd3a4ef7a47f11f9da597b6e4ee9a4174a7abd /dev-python/pyalsa
parentdev-python/ytmusicapi: Remove old (diff)
downloadgentoo-a9b097e7af09b2d3303c981f4aa5f23d17d3d804.tar.gz
gentoo-a9b097e7af09b2d3303c981f4aa5f23d17d3d804.tar.bz2
gentoo-a9b097e7af09b2d3303c981f4aa5f23d17d3d804.zip
dev-python/pyalsa: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyalsa')
-rw-r--r--dev-python/pyalsa/pyalsa-1.2.7-r1.ebuild55
-rw-r--r--dev-python/pyalsa/pyalsa-1.2.7.ebuild44
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.2.7-r1.ebuild b/dev-python/pyalsa/pyalsa-1.2.7-r1.ebuild
deleted file mode 100644
index bc1ff7849d92..000000000000
--- a/dev-python/pyalsa/pyalsa-1.2.7-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-# py3.12: https://github.com/alsa-project/alsa-python/issues/8
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for ALSA library"
-HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
-SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-# Needs access to system's alsa configuration/devices
-RESTRICT="test"
-
-DEPEND="
- media-libs/alsa-lib
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch"
-)
-
-python_test() {
- cd "${T}" || die
-
- shopt -s nullglob
- local test
- local failed
- for test in "${S}"/test/*.py ; do
- ${EPYTHON} "${test}" || {
- eerror "${test} failed with ${EPYTHON}"
- failed=1
- break
- }
- done
- shopt -u nullglob
-
- if [[ ${failed} -eq 1 ]] ; then
- die "${test} failed with ${EPYTHON}"
- fi
-}
diff --git a/dev-python/pyalsa/pyalsa-1.2.7.ebuild b/dev-python/pyalsa/pyalsa-1.2.7.ebuild
deleted file mode 100644
index 3840bf92b6eb..000000000000
--- a/dev-python/pyalsa/pyalsa-1.2.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for ALSA library"
-HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
-SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-# Needs access to system's alsa configuration/devices
-RESTRICT="test"
-
-RDEPEND="media-libs/alsa-lib"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch" )
-
-python_test() {
- cd "${T}" || die
-
- shopt -s nullglob
- local test
- local failed
- for test in "${S}"/test/*.py ; do
- ${EPYTHON} "${test}" || {
- eerror "${test} failed with ${EPYTHON}"
- failed=1
- break
- }
- done
- shopt -u nullglob
-
- if [[ ${failed} -eq 1 ]] ; then
- die "${test} failed with ${EPYTHON}"
- fi
-}