summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-07 01:05:15 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-07 01:11:33 +0200
commit87a2e3007b1a04229358ff4d0eacdaf82d7a8177 (patch)
treeaf385ef63f1dda48dde822e0398ab583b0355c35 /dev-python/pushbullet-py
parentdev-python/flask-nav: enable py310, update EAPI 7 -> 8 (diff)
downloadgentoo-87a2e3007b1a04229358ff4d0eacdaf82d7a8177.tar.gz
gentoo-87a2e3007b1a04229358ff4d0eacdaf82d7a8177.tar.bz2
gentoo-87a2e3007b1a04229358ff4d0eacdaf82d7a8177.zip
dev-python/pushbullet-py: enable py3.10
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
index 0ac0e801d0dd..77ea383ad825 100644
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
+++ b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -33,9 +33,8 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- # skip tests which require network access
- PUSHBULLET_API_KEY= pytest -vv \
- -k "not (test_auth or test_decryption)" \
+ # Skip tests which require internet access
+ PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)" \
|| die "Tests failed with ${EPYTHON}"
}