summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 10:19:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 10:28:12 +0200
commit826a6bd850ec609f96e8702ba7c11eb992cb9cd2 (patch)
tree1b4401ad4b3cfecc9239a9448b6d63d499a5d8f1 /dev-python/pushbullet-py
parentdev-python/browser-cookie3: Remove old (diff)
downloadgentoo-826a6bd850ec609f96e8702ba7c11eb992cb9cd2.tar.gz
gentoo-826a6bd850ec609f96e8702ba7c11eb992cb9cd2.tar.bz2
gentoo-826a6bd850ec609f96e8702ba7c11eb992cb9cd2.zip
dev-python/pushbullet-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
deleted file mode 100644
index 53c34a84b140..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{9..10} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="https://github.com/randomchars/pushbullet.py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Skip tests which require internet access
- PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}