summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-27 21:32:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-27 22:08:35 +0300
commit338a35e3edfb1c02566c61f116cbcb69dd26b0c7 (patch)
treedb46ae1636e36e78bf63b3b140efc556387108a8 /dev-python/prompt_toolkit
parenttoolchain-funcs.eclass: set LC_ALL=C where appropriate (diff)
downloadgentoo-338a35e3edfb1c02566c61f116cbcb69dd26b0c7.tar.gz
gentoo-338a35e3edfb1c02566c61f116cbcb69dd26b0c7.tar.bz2
gentoo-338a35e3edfb1c02566c61f116cbcb69dd26b0c7.zip
dev-python/prompt_toolkit: add 3.0.30
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index b9847720ae43..e44592fae868 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.29.tar.gz 417831 BLAKE2B f46ff507c991f6bf9536f0161cc79734013c53dddd9053076a8da7532233138fd179c6adb009af575329b3a78ab5bf6ef34e3d8eba1f5cf80cca951a32cfcc04 SHA512 a0d1562fe4ced52972ca7ee3bc9fe158865461b28be393436651f326cf2ddf0553d49ac8051ed700ef95d3ce2a76b9fcc10d92b6890203aca4e27e050cb814c0
+DIST prompt_toolkit-3.0.30.tar.gz 418985 BLAKE2B 2edc5024e22ccf60ab68afef9958eead5711b88f4f2abfde387e626893778eda5203f855a5590776b25efb3fccea87012d01e39551d192861841dab188d149e8 SHA512 cb0b9d71b09c353f2674052d75ec16a1803e0868ff5dd5625eefae767d45699b1b6bb99e4d98d3bca7ced7b60f52806ec10ed7ccab8a830c62d51baeeace23f7
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild
new file mode 100644
index 000000000000..daef0b2a5e76
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest