summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:08:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:08:20 +0300
commit8314a787631bfeaecf2c8d417e888c649a6ec295 (patch)
tree1bf5dc4d62f447dfbb43874c4eb2db82728f7d20 /dev-python/prettytable
parentdev-python/websocket-client: add 1.4.0 (diff)
downloadgentoo-8314a787631bfeaecf2c8d417e888c649a6ec295.tar.gz
gentoo-8314a787631bfeaecf2c8d417e888c649a6ec295.tar.bz2
gentoo-8314a787631bfeaecf2c8d417e888c649a6ec295.zip
dev-python/prettytable: add 3.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index b7fdc06177a8..66e32ec17cf4 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1 +1,2 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
+DIST prettytable-3.4.0.tar.gz 54901 BLAKE2B c15d936cc5d31a4df010a51c3f6bdc3e8485859b0df2ebccd917922ed5ca5419227e16aa10b4ca896fbb942573f7fdf1532443f0680174a7f07fde32f718af1b SHA512 3d79007d113737653a871f6ef23d8631cd2810a0c44436933ff063efeaa36d91bc2a98cd7dda526e459c0fbb522ed1f1dd4f45dd0c7c55e24f5b1a0c22bd90d3
diff --git a/dev-python/prettytable/prettytable-3.4.0.ebuild b/dev-python/prettytable/prettytable-3.4.0.ebuild
new file mode 100644
index 000000000000..20477a0624fb
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest