summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-09 09:37:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-13 06:52:33 +0200
commitb025ab91f84ec8ba99e0b462c261f1adb6dc43e8 (patch)
treeb733c23375322dd44ae961d766ab2cc894eff84b /dev-python/pip
parentprofiles: Introduce test-rust flag to control Rust test deps (diff)
downloadgentoo-b025ab91f84ec8ba99e0b462c261f1adb6dc43e8.tar.gz
gentoo-b025ab91f84ec8ba99e0b462c261f1adb6dc43e8.tar.bz2
gentoo-b025ab91f84ec8ba99e0b462c261f1adb6dc43e8.zip
dev-python/pip: Use test-rust flag for cryptography dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/pip-22.2.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pip/pip-22.2.2.ebuild b/dev-python/pip/pip-22.2.2.ebuild
index 1cfe45d40d06..ff18a3946fa0 100644
--- a/dev-python/pip/pip-22.2.2.ebuild
+++ b/dev-python/pip/pip-22.2.2.ebuild
@@ -41,7 +41,7 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MPL-2.0 PSF-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
-IUSE="vanilla"
+IUSE="test-rust vanilla"
RDEPEND="
>=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
@@ -57,9 +57,9 @@ BDEPEND="
dev-python/tomli-w[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
- !alpha? ( !arm? ( !hppa? ( !ia64? ( !s390? ( !sparc? (
+ test-rust? (
dev-python/cryptography[${PYTHON_USEDEP}]
- ) ) ) ) ) )
+ )
' "${PYTHON_TESTED[@]}")
)
"