summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-24 19:34:56 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-24 20:31:44 +0100
commita8474a05b0f0353e1ddc69e5d865e7f1bd01fb02 (patch)
treef2273cbb536af18bfdc7f73c3b550c4343b0ee30 /dev-python/pip
parentsys-devel/gcc: restore 7.3.0-r6, bug #701050 (diff)
downloadgentoo-a8474a05b0f0353e1ddc69e5d865e7f1bd01fb02.tar.gz
gentoo-a8474a05b0f0353e1ddc69e5d865e7f1bd01fb02.tar.bz2
gentoo-a8474a05b0f0353e1ddc69e5d865e7f1bd01fb02.zip
dev-python/pip: Remove unnecessary test deps and restrictions
Remove pytest version restriction, pytest-4 gives the same result. Remove unused pytest-cov. Remove unnecessary pytest-rerunfailures and pytest-timeout (they do not affect the result). Finally, remove pytest-xdist -- while tests are obviously slower without it, it's very unstable and frequently causes crash before tests even start. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/pip-19.3.1-r1.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/dev-python/pip/pip-19.3.1-r1.ebuild b/dev-python/pip/pip-19.3.1-r1.ebuild
index 5db9420caa27..b0232bd55f9a 100644
--- a/dev-python/pip/pip-19.3.1-r1.ebuild
+++ b/dev-python/pip/pip-19.3.1-r1.ebuild
@@ -40,11 +40,7 @@ DEPEND="
dev-python/freezegun[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
- <dev-python/pytest-4[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- <dev-python/pytest-rerunfailures-7.0[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- <dev-python/pytest-xdist-1.28.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/scripttest[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
@@ -92,8 +88,6 @@ python_test () {
# version_check tests are excluded since we explicitly disable this feature entirely.
# uninstall test just fails, likely because of our test environment setup.
python -m pytest -v \
- -n $(makeopts_jobs) \
- --timeout 300 \
-k "not (svn or git or bazaar or mercurial or version_check or uninstall_non_local_distutils ${EXCLUDE_TESTS[*]})" \
-m "not network" \
|| die