summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-22 06:46:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-22 08:17:09 +0200
commit2d4bd3302c6f5ed7773302f73623e2e77c70d9cf (patch)
tree4a5581072fc788ca576b93d5bd2ae99069e61952 /dev-python/peewee
parentdev-python/tornado: Bump to 6.3.1 (diff)
downloadgentoo-2d4bd3302c6f5ed7773302f73623e2e77c70d9cf.tar.gz
gentoo-2d4bd3302c6f5ed7773302f73623e2e77c70d9cf.tar.bz2
gentoo-2d4bd3302c6f5ed7773302f73623e2e77c70d9cf.zip
dev-python/peewee: Bump to 3.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.16.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 46f1cfb03bd1..bfdc50ac4435 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1,3 @@
DIST peewee-3.16.0.gh.tar.gz 1085430 BLAKE2B 3acfbbc9d8cce7e4bd1c0027905f4ca44431f376a243adffbfadd4d3f15b4e729c4736076e8ec72c40261ca269c66d811afb6c25b9d075d5913a13869da4f4dd SHA512 f77a040831bd3189135196ede9748c92af9db21127839dfacd7712586273bdd22c688ca22bfa373805fa1b64f770b7cea850cba53e73f324f25ced1305830409
DIST peewee-3.16.1.gh.tar.gz 911668 BLAKE2B 6336d2edbf85b54dd98b3a67fc9507c626eee1d85293b12cf60d3a733d243d70a7df0583cd6024cb0550f8f31229702404692b0bf588e3c46e104ad64a095f37 SHA512 e89f1a2f25c2675403a560d3fa8eade833f9ef8b2fecfef00769a9633e99cb40feff7c4e1d2e9b001d4e6f50a8dae4594ffe22adfbe64a93035c47f673d5557c
+DIST peewee-3.16.2.gh.tar.gz 912162 BLAKE2B d865a63fb0eeff064b6655029741291ebd002ffa428fe98f87b319874713064eed9500fb45e3710b7e1223ea2537408d51dc4a6f40b525467f074f225c05bf20 SHA512 7e507d9f2ace45c5ec482d657e7722812fae10eea9a23b12caf2611d3739bc6dc70800f21d606d5e854e3209dd6d2ff73b93f004515f6549c3bbc423bce650d8
diff --git a/dev-python/peewee/peewee-3.16.2.ebuild b/dev-python/peewee/peewee-3.16.2.ebuild
new file mode 100644
index 000000000000..db2b218c25a9
--- /dev/null
+++ b/dev-python/peewee/peewee-3.16.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples +native-extensions test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ native-extensions? ( dev-db/sqlite:3= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+src_compile() {
+ if ! use native-extensions; then
+ local -x NO_SQLITE=1
+ fi
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}