summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 07:29:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 08:04:31 +0200
commit704678ef03dbd007a65296e4e2fa127453bc606f (patch)
tree39255849a833a873b7f3528d77f74d74730fc7bd /dev-python/packaging
parentdev-python/rich: Bump to 13.3.4 (diff)
downloadgentoo-704678ef03dbd007a65296e4e2fa127453bc606f.tar.gz
gentoo-704678ef03dbd007a65296e4e2fa127453bc606f.tar.bz2
gentoo-704678ef03dbd007a65296e4e2fa127453bc606f.zip
dev-python/packaging: Bump to 23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-23.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index e61e9b7a2f3e..c12a7c4f9561 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1,3 @@
DIST packaging-21.3.gh.tar.gz 80471 BLAKE2B a16ba1e74f0c868816131a7cb07b7aa0c14760cf3ad4c3d6737ac30ef99276c33b1f018d29e710f28e8d0cfb0e3e6b91e375d1d17e2b7ec6302164377cd503d0 SHA512 8960deacda26877b73d98a3b632e760e902a16ec7a04707f84044980e4d4fb33e4f584db115c9008066aa876079f28633bafe37fbd5ce9a23830b6b89eb4ae7a
DIST packaging-23.0.gh.tar.gz 84318 BLAKE2B b600fc124e368ce583e16c3f4ee478e5774a830818884ff29c797410675c206b37e3cbac8e9ddd724b40ce53c00b1f0b6a58a9dacc1988e3bf59165b656b134b SHA512 5dd2f4a596e5a1ed01b461a37e063573f5ae08e181df40377a167fe2483205b3d965e10dc403cd173d0f87e0bdcae3cde05bd39024783fbe44541d0f777d94de
+DIST packaging-23.1.tar.gz 134240 BLAKE2B ef7ef320a98592769078581e32fcc355d05f6fbb7611e7bd83fd2ed64d5f5f5d9c1f89c2a4a91ace1221214a9047e233d8d6a339fd29066b3695137ec5a870bd SHA512 0f2246b8bfeb467623ee72e6fdb7c0416e3b4ba0e00102c1528581e0835cc8e731a812b15e2e429d3ebb0001713d95cc2675f443f4597b092e305a3ef2e9137a
diff --git a/dev-python/packaging/packaging-23.1.ebuild b/dev-python/packaging/packaging-23.1.ebuild
new file mode 100644
index 000000000000..670c988ba205
--- /dev/null
+++ b/dev-python/packaging/packaging-23.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/
+"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.7-r1[${PYTHON_USEDEP}]
+ !<dev-python/setuptools-67
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}