summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/odo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/odo')
-rw-r--r--dev-python/odo/Manifest2
-rw-r--r--dev-python/odo/metadata.xml9
-rw-r--r--dev-python/odo/odo-0.3.2.ebuild50
-rw-r--r--dev-python/odo/odo-0.3.3.ebuild50
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/odo/Manifest b/dev-python/odo/Manifest
new file mode 100644
index 000000000000..2223c0fcda6f
--- /dev/null
+++ b/dev-python/odo/Manifest
@@ -0,0 +1,2 @@
+DIST odo-0.3.2.zip 142291 SHA256 515365ec8b67c7c73303391b8f12107be6a8f4ab983352f548dcb32f8eb175e5 SHA512 c2a0dc2f62225bb394fc5f01476a9159310c798f7ea115ccf6e292d99c666509a0e6ef10c50c47c491ffdc805046152a9d75f90940153fbba4382426a07354b7 WHIRLPOOL 74ee63848e20b8936d6608f240c449bf3d81916bf40be51723fd7f519139474fa74f477bc3e835c9988e8926e12510a5e234817291240a1ae4aeefbb0a8c0cb3
+DIST odo-0.3.3.tar.gz 109748 SHA256 2499ee86c26c74daa28f21ed235ca331911065950deea5169ebdb7d5dae6ebef SHA512 7c470ea5a24ab5ccc3e72d1cbb4dcd2d370bb5de6ee5d8f1dafb8215db057f920d61470dbba02e5510ee5700fe86f2ae842bbc2bbbedf20e801789998b9c714e WHIRLPOOL 8c5329310a33d890452de8d9156f207ab294b26a68722719f375f2da4bef8fd23b47aee883c4a5c79e0f39cc30eb5eaab544e3f02c34b24062c6c2c2bfc146c3
diff --git a/dev-python/odo/metadata.xml b/dev-python/odo/metadata.xml
new file mode 100644
index 000000000000..bbfce266d3f9
--- /dev/null
+++ b/dev-python/odo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">odo</remote-id>
+ <remote-id type="github">ContinuumIO/odo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/odo/odo-0.3.2.ebuild b/dev-python/odo/odo-0.3.2.ebuild
new file mode 100644
index 000000000000..e17aee79bd0e
--- /dev/null
+++ b/dev-python/odo/odo-0.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data migration in python"
+HOMEPAGE="https://github.com/ContinuumIO/odo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ doc? ( dev-python/docutils )"
+RDEPEND=">=dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ "
+
+python_prepare_all() {
+ sed -e '/.. toctree::/d' -i docs/source/index.rst|| die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs/source > /dev/null
+ mkdir ../build || die
+ local i;
+ for i in ./*
+ do
+ rst2html.py $i > ../build/${i/rst/html} || die
+ done
+ popd > /dev/null
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/odo/odo-0.3.3.ebuild b/dev-python/odo/odo-0.3.3.ebuild
new file mode 100644
index 000000000000..dd0574d8ff85
--- /dev/null
+++ b/dev-python/odo/odo-0.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data migration in python"
+HOMEPAGE="https://github.com/ContinuumIO/odo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ doc? ( dev-python/docutils )"
+RDEPEND=">=dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ "
+
+python_prepare_all() {
+ sed -e '/.. toctree::/d' -i docs/source/index.rst|| die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs/source > /dev/null
+ mkdir ../build || die
+ local i;
+ for i in ./*
+ do
+ rst2html.py $i > ../build/${i/rst/html} || die
+ done
+ popd > /dev/null
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}