summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:56 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:56 +0100
commit4ea4752f1c13b3ef0ec034da84f3ee95906a2d16 (patch)
treed8a5ed33b54d0d3e91129b833e6b778a7fad94a3 /dev-python/odo
parentdev-python/moto: Remove old (diff)
downloadgentoo-4ea4752f1c13b3ef0ec034da84f3ee95906a2d16.tar.gz
gentoo-4ea4752f1c13b3ef0ec034da84f3ee95906a2d16.tar.bz2
gentoo-4ea4752f1c13b3ef0ec034da84f3ee95906a2d16.zip
dev-python/odo: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/odo')
-rw-r--r--dev-python/odo/odo-0.5.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/odo/odo-0.5.0.ebuild b/dev-python/odo/odo-0.5.0.ebuild
deleted file mode 100644
index 1ee3129a83e8..000000000000
--- a/dev-python/odo/odo-0.5.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Data migration in python"
-HOMEPAGE="https://github.com/ContinuumIO/odo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="app-arch/unzip
- doc? ( dev-python/docutils )"
-RDEPEND=">=dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- "
-
-python_prepare_all() {
- sed -e '/.. toctree::/d' -i docs/source/index.rst|| die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- pushd docs/source > /dev/null
- mkdir ../build || die
- local i;
- for i in ./*
- do
- rst2html.py $i > ../build/${i/rst/html} || die
- done
- popd > /dev/null
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/. )
- distutils-r1_python_install_all
-}