summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-29 21:57:50 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-29 22:18:15 +0200
commit5bacb571c81c77f6e72615d4ed76adef09fee390 (patch)
treeea7e4e5bcb213377c1745829b7d6ec5687c3272f /dev-python/nbclient
parentdev-python/pyupgrade: add 3.2.3 (diff)
downloadgentoo-5bacb571c81c77f6e72615d4ed76adef09fee390.tar.gz
gentoo-5bacb571c81c77f6e72615d4ed76adef09fee390.tar.bz2
gentoo-5bacb571c81c77f6e72615d4ed76adef09fee390.zip
dev-python/nbclient: add 0.7.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.7.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index a8ae858da37a..e67586f0a8da 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1 +1,2 @@
DIST nbclient-0.7.0.gh.tar.gz 78253 BLAKE2B 473dcef140c8e1fc8f1e97fa30859b9b9fc2dfd6f951ae52db8ab11febbb3de7f60d129424827983a2c05579cd2340e9d4e1a9d0e452a7678497fc1c7176ecf3 SHA512 93d22e2b4fe1740798b812bb4890bf2fe2c7fdd337e34b50eac3140ead73d443cdb326948b2e8511b6ccad61c7daf1efd8e7cc3664b6b1ad9dda0894ca84fff5
+DIST nbclient-0.7.2.gh.tar.gz 76883 BLAKE2B d90b9dd7b15757a44c86084b68b916aab663c0e20a5c1012bda9f86a0ec1104a01cd78d27bc6e510eceeee12f2356a312d8080e1568e4c54dd2e916af85dc304 SHA512 17f1bfbfa156688e895ab1a0d0f74903f43c62a373a40cfcc50a654d86ebbaeb5ed101562716140a3878a9667bb131c49e06caf2e3127160700baf181cd1c29b
diff --git a/dev-python/nbclient/nbclient-0.7.2.ebuild b/dev-python/nbclient/nbclient-0.7.2.ebuild
new file mode 100644
index 000000000000..bef4d0ab4373
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.7.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.12[${PYTHON_USEDEP}]
+ <dev-python/jupyter_core-5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
+}