summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-04 07:51:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-04 10:05:46 +0200
commitab887b7e160500f19485d47b064c35de528897db (patch)
tree7544d1772f4f43727a1d674aed7f9e55b2cc7687 /dev-python/multidict
parentdev-python/pytest-cov: Bump to 3.0.0 (diff)
downloadgentoo-ab887b7e160500f19485d47b064c35de528897db.tar.gz
gentoo-ab887b7e160500f19485d47b064c35de528897db.tar.bz2
gentoo-ab887b7e160500f19485d47b064c35de528897db.zip
dev-python/multidict: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-5.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index 260184259127..a7fc77d26f6c 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1 +1,2 @@
DIST multidict-5.1.0.tar.gz 58801 BLAKE2B 9b9194447a7d91d673b07e440d5f1d2068c79b15890c63a5ab679016b02471996adc73173bb303c14609b2aec230d8ebda36ab978b22b67c008f6b03e6f663f2 SHA512 7dfc8862048d274f37341dda72d93c0fab6d5463fade4f5e241f5b8bf65dcea5c0b5120376847a77f00c7246e87a1cfe14502b6f64bf97e4d00594fed6735466
+DIST multidict-5.2.0.tar.gz 56984 BLAKE2B 3580e3f53b3ec581d338676647f2e8dd78387fdad5730fe703c02b3cd4182d69e3b6896d71bd969413dd27974e07272cc541701a2145a517d9bacea45000e9c8 SHA512 508b6db9219c3dae76da5e89a398f4541beff2a875030c2f11da9aaa1e001324d069d7a291148c510fe555cb3a33288ef297c9baa863e42d3d09d60588bebd7e
diff --git a/dev-python/multidict/multidict-5.2.0.ebuild b/dev-python/multidict/multidict-5.2.0.ebuild
new file mode 100644
index 000000000000..f2f50b751720
--- /dev/null
+++ b/dev-python/multidict/multidict-5.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND=">=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}