summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 12:14:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 15:15:33 +0200
commit688c2ecd719c6fe8087fbd0f242e4d70821e7d49 (patch)
treeb5f112131e59ab1524811aabfc92c0db69ca60df /dev-python/mistune
parentdev-python/m2crypto: Bump to version 0.26.0 (diff)
downloadgentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.tar.gz
gentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.tar.bz2
gentoo-688c2ecd719c6fe8087fbd0f242e4d70821e7d49.zip
dev-python/mistune: Bump to version 0.7.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/mistune')
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/mistune-0.7.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
index a87ac6dc57ff..197a5a3162b8 100644
--- a/dev-python/mistune/Manifest
+++ b/dev-python/mistune/Manifest
@@ -1 +1,2 @@
DIST mistune-0.7.2.tar.gz 48887 SHA256 626f2516adcde4af608eaf83635ff20ff7e577c1898ad4d0f0fcd8c094399840 SHA512 9002bf83a368671389f05928f4f689064a1e415e54309259b6bbb7781b4bfddbbf834e2c63ed3271e1e6ec7b78c1665c7708177b9723433d1e2ad4b13ad903ca WHIRLPOOL 54d95b82bb061709a48bbd3e87a16e4cc03734f8adfc88e48b44da0070e16ec062ea4c219e258bd4abd2a4e7dd6aa144a4f73257c24ee28622eb36fcba89effe
+DIST mistune-0.7.4.tar.gz 49304 SHA256 8517af9f5cd1857bb83f9a23da75aa516d7538c32a2c5d5c56f3789a9e4cd22f SHA512 d300bec23f5482396c6f282ee3d773461c162791e4605ca40141eb9487c8b158ac7f47f6338f7c3bf27bc614292ecc61dfbf419d47eab817821f18cf80103802 WHIRLPOOL fbbb9bee4078aa25e2934fc0163306c24c7169e350e0816babad8a4dd7f305c8be8b4935a427f7266c05d640427a68eebe23e3c42cabd372252f0d8811a091e7
diff --git a/dev-python/mistune/mistune-0.7.4.ebuild b/dev-python/mistune/mistune-0.7.4.ebuild
new file mode 100644
index 000000000000..782a3404807d
--- /dev/null
+++ b/dev-python/mistune/mistune-0.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.python.org/pypi/mistune https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}