summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-17 03:30:40 +0100
committerSam James <sam@gentoo.org>2023-08-17 03:54:19 +0100
commit8c56493447b24840837af00958ecebf604c1ed17 (patch)
tree423b767e6a7ab04f01fce7d999208350915fc491 /dev-python/matplotlib
parentvirtual/dist-kernel: Bump to 5.4.254 (diff)
downloadgentoo-8c56493447b24840837af00958ecebf604c1ed17.tar.gz
gentoo-8c56493447b24840837af00958ecebf604c1ed17.tar.bz2
gentoo-8c56493447b24840837af00958ecebf604c1ed17.zip
dev-python/matplotlib: update hppa skip list
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.7.1.ebuild30
-rw-r--r--dev-python/matplotlib/matplotlib-3.7.2.ebuild30
2 files changed, 52 insertions, 8 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.7.1.ebuild b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
index 135d1b285cf8..55747a1aa126 100644
--- a/dev-python/matplotlib/matplotlib-3.7.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
@@ -268,11 +268,33 @@ python_test() {
esac
if use hppa ; then
- EPYTEST_IGNORE+=(
- tests/test_mathtext.py
- )
-
EPYTEST_DESELECT+=(
+ 'tests/test_mathtext.py::test_mathtext_exceptions[hspace without value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[hspace with invalid value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[function without space]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[accent without space]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[frac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[frac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[binom without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[binom with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[genfrac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[genfrac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[sqrt without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[sqrt with invalid value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overline without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overline with empty parameter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[left with invalid delimiter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[right with invalid delimiter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unclosed parentheses with sizing]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unclosed parentheses without sizing]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[dfrac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[dfrac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overset without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[underset without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unknown symbol]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[double superscript]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[double subscript]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[super on sub without braces]'
'tests/test_quiver.py::test_barbs[png]'
'tests/test_quiver.py::test_barbs_pivot[png]'
'tests/test_quiver.py::test_barbs_flip[png]'
diff --git a/dev-python/matplotlib/matplotlib-3.7.2.ebuild b/dev-python/matplotlib/matplotlib-3.7.2.ebuild
index f6e948e0c338..8fad3f941931 100644
--- a/dev-python/matplotlib/matplotlib-3.7.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.7.2.ebuild
@@ -273,11 +273,33 @@ python_test() {
esac
if use hppa ; then
- EPYTEST_IGNORE+=(
- tests/test_mathtext.py
- )
-
EPYTEST_DESELECT+=(
+ 'tests/test_mathtext.py::test_mathtext_exceptions[hspace without value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[hspace with invalid value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[function without space]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[accent without space]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[frac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[frac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[binom without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[binom with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[genfrac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[genfrac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[sqrt without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[sqrt with invalid value]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overline without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overline with empty parameter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[left with invalid delimiter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[right with invalid delimiter]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unclosed parentheses with sizing]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unclosed parentheses without sizing]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[dfrac without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[dfrac with empty parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[overset without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[underset without parameters]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[unknown symbol]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[double superscript]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[double subscript]'
+ 'tests/test_mathtext.py::test_mathtext_exceptions[super on sub without braces]'
'tests/test_quiver.py::test_barbs[png]'
'tests/test_quiver.py::test_barbs_pivot[png]'
'tests/test_quiver.py::test_barbs_flip[png]'