summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-24 19:25:26 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-24 19:58:20 +0200
commitc2c342075bb8f8a17dca2de44b41a62f72d1a852 (patch)
treef5165d5bd7963fad9e8a606a6ee978c5b224bdca /dev-python/mando
parentdev-python/pytest-codeblocks: drop 0.9.0, 0.12.2 (diff)
downloadgentoo-c2c342075bb8f8a17dca2de44b41a62f72d1a852.tar.gz
gentoo-c2c342075bb8f8a17dca2de44b41a62f72d1a852.tar.bz2
gentoo-c2c342075bb8f8a17dca2de44b41a62f72d1a852.zip
dev-python/mando: add 0.7.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/Manifest1
-rw-r--r--dev-python/mando/mando-0.7.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index cadf33026638..908227712918 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1 +1,2 @@
DIST mando-0.6.4.tar.gz 36560 BLAKE2B 9878746485d4b896c3e32512b77ac02739940a1398eee12056fd6719cc3c99f8c526c8e573d2556b6a9d0d8d26e20fb45c97119e626b1d44f0a5b5f4655adba1 SHA512 457fa0db4e8e5dbfac6146d254181213814ef1975c919b4573007face27749ec3a50eda850558ebdc0fdff94a5e9819fd825b10cb3023078b2b426c2825fdbf0
+DIST mando-0.7.1.gh.tar.gz 37802 BLAKE2B 1caf437248f1b1397888674fff0171680fd1d2cffd1d3394869edce4fef0d214fb52fc0eb7435ef162722f128f129f8d19385e65661914c51f78108b64f8db38 SHA512 a25dfd57e833416cbd64933ca3970712d28c2e2ed172091a0d0c082f486c707d0061afb071e3973e7e42b654d1a6e70f4909b1254fdef493471dc0ae9d3eb62b
diff --git a/dev-python/mando/mando-0.7.1.ebuild b/dev-python/mando/mando-0.7.1.ebuild
new file mode 100644
index 000000000000..89f6b4003d36
--- /dev/null
+++ b/dev-python/mando/mando-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Create Python CLI apps with little to no effort at all!"
+HOMEPAGE="https://mando.readthedocs.io/ https://github.com/rubik/mando/"
+SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}