summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-19 21:48:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-19 22:10:44 +0200
commitb8ebb20fc20477473e0dc887dfe50389c8898af5 (patch)
treef4f56b2fbc6092a4846436471b7e9a71677ae5c9 /dev-python/lit
parentsys-devel/llvm: Remove 7.0.9999 (diff)
downloadgentoo-b8ebb20fc20477473e0dc887dfe50389c8898af5.tar.gz
gentoo-b8ebb20fc20477473e0dc887dfe50389c8898af5.tar.bz2
gentoo-b8ebb20fc20477473e0dc887dfe50389c8898af5.zip
dev-python/lit: Remove 7.0.9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-7.0.9999.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/lit/lit-7.0.9999.ebuild b/dev-python/lit/lit-7.0.9999.ebuild
deleted file mode 100644
index aa749c9b66f7..000000000000
--- a/dev-python/lit/lit-7.0.9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit distutils-r1 git-r3 multiprocessing
-
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_70"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${P}/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' utils/lit
-}
-
-python_test() {
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
-}