summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/keyczar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/keyczar')
-rw-r--r--dev-python/keyczar/Manifest2
-rw-r--r--dev-python/keyczar/keyczar-0.715.ebuild38
-rw-r--r--dev-python/keyczar/keyczar-0.71c.ebuild31
-rw-r--r--dev-python/keyczar/metadata.xml8
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/keyczar/Manifest b/dev-python/keyczar/Manifest
new file mode 100644
index 000000000000..b338c60e1b2b
--- /dev/null
+++ b/dev-python/keyczar/Manifest
@@ -0,0 +1,2 @@
+DIST python-keyczar-0.715.tar.gz 242151 SHA256 f43f9f15b0b719de94cab2754dcf78ef63b40ee2a12cea296e7af788b28501bb SHA512 e0733ad488db2a2803227db6f140c5f316425782a780070e6fd4227d3b88d523e2c41743cd3a6e14e535c7dbdf7b50b428d15d26ca5cfb35e2841a5f71b709f3 WHIRLPOOL b93ec173970f4857e1991e0fe08e3e0ac9c8243dad2f5d63b362711f100da2861c878ea0b5ee44aae54594404d9e77d4d8420c9b54004d3019d6b00995535354
+DIST python-keyczar-0.71c.tar.gz 237244 SHA256 37707db2af3dde1c7e087b8a8f72ce3bef376889a3a358a72fe66e83318fb0a2 SHA512 7123d84701d245bbd51c9760fccb49f6664d93337433054f2deb95ca0428ed994b77494465b93a142e6778f9bcd968e99d93a2805dd5368fd34d2bb2abaf1d58 WHIRLPOOL 5d78934d080294b22d3785739edf76e8dde6579a207de2cfacf7b0d6e33ba490a647a2857a0b927563f0e97f006bf806347082cf586859a155dc46af355b7ab7
diff --git a/dev-python/keyczar/keyczar-0.715.ebuild b/dev-python/keyczar/keyczar-0.715.ebuild
new file mode 100644
index 000000000000..feab47b8d9aa
--- /dev/null
+++ b/dev-python/keyczar/keyczar-0.715.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 ) #appears py2 friendly only
+
+inherit distutils-r1
+
+MY_PN=python-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Toolkit for safe and simple cryptography"
+HOMEPAGE="http://www.keyczar.org https://pypi.python.org/pypi/python-keyczar/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pycrypto-2.0[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ cd tests/keyczar_tests
+ ${PYTHON} alltests.py || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dodoc doc/pycrypt*
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/keyczar/keyczar-0.71c.ebuild b/dev-python/keyczar/keyczar-0.71c.ebuild
new file mode 100644
index 000000000000..3ec65224c840
--- /dev/null
+++ b/dev-python/keyczar/keyczar-0.71c.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=python-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Toolkit for safe and simple cryptography"
+HOMEPAGE="http://www.keyczar.org https://pypi.python.org/pypi/python-keyczar/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pycrypto-2.0[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ cd "${S}"/tests/keyczar_tests
+ ${PYTHON} alltests.py || die "tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/keyczar/metadata.xml b/dev-python/keyczar/metadata.xml
new file mode 100644
index 000000000000..0a3e6626ed64
--- /dev/null
+++ b/dev-python/keyczar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">python-keyczar</remote-id>
+ </upstream>
+</pkgmetadata>