summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:11:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:16 +0200
commit8f2c401bd3389f2a5d24d2ba17761daab5f68254 (patch)
tree2fd026cff53efb9f3074ee592d60730045c1d2c1 /dev-python/jsonpointer
parentdev-python/jsondiff: Bump to 2.0.0 (diff)
downloadgentoo-8f2c401bd3389f2a5d24d2ba17761daab5f68254.tar.gz
gentoo-8f2c401bd3389f2a5d24d2ba17761daab5f68254.tar.bz2
gentoo-8f2c401bd3389f2a5d24d2ba17761daab5f68254.zip
dev-python/jsonpointer: Bump to 2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest1
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 9913b49f2ecf..a825d572f0a9 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1 +1,2 @@
DIST jsonpointer-2.2.tar.gz 8292 BLAKE2B 837c6c8a87e0d19cbeed07769afb29fa56ddfb629f05d0f2de94f4e94af916358f71892e085c7c18b9c711ac8e604a0ff7d1fa7dfbf52836edb1a600e5ed390b SHA512 ce680e3915ea9db915095c4106e58acf7cc2148bdc67944e03e225a33b882964ed0c154fdbe8415f787c5aa5bfa007b9e1fd2a31689dcadc88b1560931ca6a6d
+DIST jsonpointer-2.3.tar.gz 9295 BLAKE2B 8a33c8ce21721b6c402a44d3d1572a767e3b7485fa1dd80baf98120c9822412841cc21e3bc2d6b7e058793ab4ade5993712c689631cb4a1237afc1d7f36e6bdf SHA512 e04da474a5ec376d1cd2c764c2d7a11ac296450df199449994cb1dedf02a49df3ae3a4e75b2963370dba1da166464602b849a79609f7a98d8246dab0b342c819
diff --git a/dev-python/jsonpointer/jsonpointer-2.3.ebuild b/dev-python/jsonpointer/jsonpointer-2.3.ebuild
new file mode 100644
index 000000000000..6fe5363d2610
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}