summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:35:26 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:38:06 +0300
commit7622f900c65bed93baa22c98c8b09cce1af77e64 (patch)
treefdb9fda6b1291d0ed16223e0968f7ab337335890 /dev-python/jpype
parentnet-news/newsboat: unmaintain (diff)
downloadgentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.gz
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.bz2
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.zip
dev-python: mass last-rites removal
Closes: https://bugs.gentoo.org/711808 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python/jpype')
-rw-r--r--dev-python/jpype/Manifest2
-rw-r--r--dev-python/jpype/files/jpype-gcc6-noexcept.patch57
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild35
-rw-r--r--dev-python/jpype/jpype-0.6.3.ebuild35
-rw-r--r--dev-python/jpype/metadata.xml19
5 files changed, 0 insertions, 148 deletions
diff --git a/dev-python/jpype/Manifest b/dev-python/jpype/Manifest
deleted file mode 100644
index acd76353d335..000000000000
--- a/dev-python/jpype/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST jpype-0.6.2.zip 260812 BLAKE2B 1e432e9d299b88d8205a2f8088123b61460772abf4fb04b5094f15c69d205d3393c2b9a31654bcfa7be4ee85d3acb702960526a14d95018c48dd012665e858f4 SHA512 f4ce5fe6e0f920f6c17bc8815c09fb54909f105fb4cf022856482680f24305a002ce00354cf44c730b34220d12f1d926971b246d0a938bb411401b0656486091
-DIST jpype-0.6.3.tar.gz 169886 BLAKE2B 26a7cd583bfb40333de99658130a6672c87998472fbfea12de888bfe9a054206d13d8b57896a7b74b79d38280f516cb6e498cd2b1d7549930ded5bcc615619a4 SHA512 49664083db6db309c56068ace713059be1fede721c7368fb3fa0ed5cde0aeb6782b2953be9c0d71f8f8028e909e67e525338da0797a5b4bcfc2325614d5849cc
diff --git a/dev-python/jpype/files/jpype-gcc6-noexcept.patch b/dev-python/jpype/files/jpype-gcc6-noexcept.patch
deleted file mode 100644
index 710844d35608..000000000000
--- a/dev-python/jpype/files/jpype-gcc6-noexcept.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=608920
-Upstream commit: https://github.com/originell/jpype/commit/3a4fb98938afd9c03070086d1b8fda8841410fa3
-
-From c3578c3488de35236f73b6eb27428b1f1526c45b Mon Sep 17 00:00:00 2001
-From: Peter-Levine <plevine457@gmail.com>
-Date: Sat, 11 Feb 2017 23:31:27 -0500
-Subject: [PATCH] Mark destructor that throws as noexcept(false) for >=C++11
-
----
- native/common/include/jp_field.h | 2 +-
- native/common/include/jpype.h | 6 ++++++
- native/common/jp_field.cpp | 2 +-
- 3 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/native/common/include/jp_field.h b/native/common/include/jp_field.h
-index d28b795..f93752c 100644
---- a/native/common/include/jp_field.h
-+++ b/native/common/include/jp_field.h
-@@ -38,7 +38,7 @@ public :
- /**
- * destructor
- */
-- virtual ~JPField();
-+ virtual ~JPField() NO_EXCEPT_FALSE;
-
- public :
- bool isStatic() const;
-diff --git a/native/common/include/jpype.h b/native/common/include/jpype.h
-index 7db5832..a492d06 100644
---- a/native/common/include/jpype.h
-+++ b/native/common/include/jpype.h
-@@ -64,6 +64,12 @@
- #define PyUnicode_FromFormat PyString_FromFormat
- #endif
-
-+// Define this and use to allow destructors to throw in C++11 or later
-+#if __cplusplus >= 201103L
-+#define NO_EXCEPT_FALSE noexcept(false)
-+#else
-+#define NO_EXCEPT_FALSE
-+#endif
-
- #include <map>
- #include <string>
-diff --git a/native/common/jp_field.cpp b/native/common/jp_field.cpp
-index 8c75e58..5ef9d8c 100644
---- a/native/common/jp_field.cpp
-+++ b/native/common/jp_field.cpp
-@@ -63,7 +63,7 @@ JPField::JPField(const JPField& fld)
- TRACE_OUT;
- }
-
--JPField::~JPField()
-+JPField::~JPField() NO_EXCEPT_FALSE
- {
- TRACE_IN("JPField::~JPField");
- JPEnv::getJava()->DeleteGlobalRef(m_Field);
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
deleted file mode 100644
index 11d20268eeb9..000000000000
--- a/dev-python/jpype/jpype-0.6.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit java-pkg-2 distutils-r1
-
-DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
-HOMEPAGE="https://github.com/originell/jpype"
-SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.zip -> ${P}.zip"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${P}"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=virtual/jdk-1.6"
-
-PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
-
-python_install() {
- use doc && local DOCS=( doc/* )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install
-}
diff --git a/dev-python/jpype/jpype-0.6.3.ebuild b/dev-python/jpype/jpype-0.6.3.ebuild
deleted file mode 100644
index f2ea32b2540f..000000000000
--- a/dev-python/jpype/jpype-0.6.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit java-pkg-2 distutils-r1
-
-DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
-HOMEPAGE="https://github.com/originell/jpype"
-SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${P}"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=virtual/jdk-1.6"
-
-#PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
-
-python_install() {
- use doc && local DOCS=( doc/* )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install
-}
diff --git a/dev-python/jpype/metadata.xml b/dev-python/jpype/metadata.xml
deleted file mode 100644
index c8bb1538ea87..000000000000
--- a/dev-python/jpype/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="github">originell/jpype</remote-id>
- </upstream>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>