summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 23:19:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 23:19:40 +0200
commitbc3b0eeb747b5824f79375ca65c182c89432e974 (patch)
treebd57e20da90442408fa25f0ce947cb557dde353c /dev-python/jaraco-logging
parentdev-python/zope-testing: Remove namespace pkg dep (diff)
downloadgentoo-bc3b0eeb747b5824f79375ca65c182c89432e974.tar.gz
gentoo-bc3b0eeb747b5824f79375ca65c182c89432e974.tar.bz2
gentoo-bc3b0eeb747b5824f79375ca65c182c89432e974.zip
dev-python/jaraco-logging: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.0-r1.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..f72cbefc5a94
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ rm "${BUILD_DIR}/install$(python_get_sitedir)"/jaraco/__init__.py || die
+}