summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-06-03 10:56:29 -0400
committerMike Gilbert <floppym@gentoo.org>2017-06-03 10:57:02 -0400
commitf74016da86dedafd7dfcd638322a4cbfc731b119 (patch)
treebdbb1d11242d9a384cd489d7623b84480401b291 /dev-python/isodate
parentapp-emulation/qemu: drop vulnerable, bug #616874 (diff)
downloadgentoo-f74016da86dedafd7dfcd638322a4cbfc731b119.tar.gz
gentoo-f74016da86dedafd7dfcd638322a4cbfc731b119.tar.bz2
gentoo-f74016da86dedafd7dfcd638322a4cbfc731b119.zip
dev-python/isodate: fix test phase
Bug: https://bugs.gentoo.org/607184 Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/isodate-0.5.4.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-python/isodate/isodate-0.5.4.ebuild b/dev-python/isodate/isodate-0.5.4.ebuild
index 4fd84aa58322..ceb2cf0a72a5 100644
--- a/dev-python/isodate/isodate-0.5.4.ebuild
+++ b/dev-python/isodate/isodate-0.5.4.ebuild
@@ -19,15 +19,5 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- local testfile
- pushd "${BUILD_DIR}"/lib/ || die
- for test in ${PN}/tests/test_*.py; do
- if ! "${PYTHON}" "${testfile}"; then
- die "Test ${testfile} failed under ${EPYTHON}"
- fi
- done
-
- # Give some order to the output salad.
- einfo "Testsuite passed under ${EPYTHON}";
- einfo ""
+ ${EPYTHON} -m unittest discover -v -s "${BUILD_DIR}/lib" || die "Testing failed with ${EPYTHON}"
}