summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:50:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:27 +0200
commit90ec95992d2ac7b871f4163f11012ed4e607695d (patch)
tree1cc31c092440ded295e5469029c2c4826de5efa8 /dev-python/hypothesis
parentdev-python/oslo-log: Bump to 5.0.0 (diff)
downloadgentoo-90ec95992d2ac7b871f4163f11012ed4e607695d.tar.gz
gentoo-90ec95992d2ac7b871f4163f11012ed4e607695d.tar.bz2
gentoo-90ec95992d2ac7b871f4163f11012ed4e607695d.zip
dev-python/hypothesis: Bump to 6.46.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 4a72f47d8927..6c146d0033a0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -10,3 +10,4 @@ DIST hypothesis-python-6.46.2.tar.gz 9305176 BLAKE2B 7d0abe4fc055eeb4660efbba990
DIST hypothesis-python-6.46.3.tar.gz 9306685 BLAKE2B a26c08361a7a58d8de8d8458a73c5c3c57f04dd2008ab31e604f0addc18fb7a52a7f4a98318498b398cd1ac5d2d718fd722c4d17e0b6ef326e0457355fda7482 SHA512 d55c3c4a57d18aa7f6d876123b09bcab32d508f5aa40048f2db7f0cab3948ebb6fab5f12d291ae4740cdd1c61c2d612c1ce804028bb59914efc132404224d1ee
DIST hypothesis-python-6.46.5.tar.gz 9307648 BLAKE2B c99116c1ff4ee812b65c80fabaea2e46cadab00865e34030485cfcd97dc8ca7232fa13fae10604f70e8408d2a4570b30c138cced37debc7906c0b0fabcfd41a5 SHA512 dc347dd5aae31512b396fd14827963aa373e4ed499063e5cd76f3bbf1724ee7482cabf4939ff4707faa37dd5e252a410a71badbc45eeef639b1b7524975c447b
DIST hypothesis-python-6.46.6.tar.gz 9308392 BLAKE2B 239579c9d7bdccc7234ddcbbccf52e825f2fe9826df182eeeb66a2c8b4affde232ed7bbd989cbac7e9a24cef879e08a891b3536a547ded33dfd0bd4fb3ac000e SHA512 f6c2b12ca95b8515514d221140318209887d8cc3df89615f3177972d847222a196a034a885e75880c12ecd4042fc01afa0a3a716aca00012b73dcbda346c3fad
+DIST hypothesis-python-6.46.7.tar.gz 9308855 BLAKE2B a26cd556bb56ff5a09987e7e4a9a46e966f26106376a4b5e481a933495f21c4a69dff0d68aa8d2006fc42794392eca35b4b68cb88e0d4695ecfe3bfe2098e9b6 SHA512 239343424df13db419bfc9057f9024ab8360cace07a0cf7d592744afa76fff54d5c30a0b7fecb41c642d034b2327feef7bec78840df25793727ce30be1aa7ef9
diff --git a/dev-python/hypothesis/hypothesis-6.46.7.ebuild b/dev-python/hypothesis/hypothesis-6.46.7.ebuild
new file mode 100644
index 000000000000..af200ba0b7c0
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.46.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}