summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-06 04:27:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-06 04:30:47 +0200
commit03800a159669d627d40761df89b406a48cd31b1f (patch)
treed2877afa588d5c979ceb2cd941087b440aaa55f2 /dev-python/humanize
parentdev-python/crispy-bootstrap4: Bump to 2024.10 (diff)
downloadgentoo-03800a159669d627d40761df89b406a48cd31b1f.tar.gz
gentoo-03800a159669d627d40761df89b406a48cd31b1f.tar.bz2
gentoo-03800a159669d627d40761df89b406a48cd31b1f.zip
dev-python/humanize: Bump to 4.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.11.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 3c086f3604c4..7490795b9077 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.10.0.tar.gz 79192 BLAKE2B 398fe1eb3b39cfc93096f7e12f057959f3e336721fe05be4bfe0bf16d3470a04a33b978c6e4ffb73c58bfb1032f9ec48b29397ef51073aa881b036427e73eb10 SHA512 973fe7aecffcc7c9b56426b5a143402a97833122e63362115ae50318c909188bbe872fbfdfaa3015298ecd44c6ebc4223d9abd202c47622066b730908a6dda44
+DIST humanize-4.11.0.tar.gz 80374 BLAKE2B 880ebf6f14c04c323528ee95c4c32c775bd2662b0d47eb6761c84024199066e69e1d571f7edc2235d81261693f1fbd3c166ec24afeb4dab28f39dd4256d37fcf SHA512 0f872b86643276bd58543d47b72719763b52ea9a434076b99d0db72d89642c2bd77e240bf506cdd04fad049fe1575919b006376d99c037936e9b9e1beb25e1a9
diff --git a/dev-python/humanize/humanize-4.11.0.ebuild b/dev-python/humanize/humanize-4.11.0.ebuild
new file mode 100644
index 000000000000..5d18d9873a5a
--- /dev/null
+++ b/dev-python/humanize/humanize-4.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/coverage/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}