summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-03 17:40:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-03 17:40:35 +0100
commit501acb94355350d330f34c7c0492ba920bfcfa10 (patch)
tree10d530da7c4d053a056d0df058ac19792e6dcfbe /dev-python/httpcore
parentsys-apps/memtest86+: attempt fix for "oversized on x86_64" (diff)
downloadgentoo-501acb94355350d330f34c7c0492ba920bfcfa10.tar.gz
gentoo-501acb94355350d330f34c7c0492ba920bfcfa10.tar.bz2
gentoo-501acb94355350d330f34c7c0492ba920bfcfa10.zip
dev-python/httpcore: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.13.3.ebuild64
-rw-r--r--dev-python/httpcore/httpcore-0.13.6.ebuild66
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 8bd60a2b8957..484d518c7e83 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1 @@
-DIST httpcore-0.13.3.tar.gz 64246 BLAKE2B afc43122a5502770b6efe7052846926e25fa678dcbd5c8ddbcd806df36dcf684d94df12571efaab0ff1b657fef14d5d71dd902be5cbec12c61db13004d7fe5a9 SHA512 7ba6c2cb77c082bcdb8cdfad2bc17646ccc9348f49760150ec1070429f94913b2fb9eae6d3407b404581b48670b866bf11696453325dd70610bd700e94990450
-DIST httpcore-0.13.6.tar.gz 64716 BLAKE2B 6eadcaac626d4561dec2e41bdbde21836727f10870093890469e6b5a4af2aa276361044d08b5e25e3bf760092e5537edff9d0c99acb1ddf6ab0a17343bcd9af2 SHA512 52b6189763755dbbd762ad26fef0107ad50949c1dd4865db788317ce981079cc095161e543f1a455ce84138b51f89806d8c55267378574feced107675f6cde47
DIST httpcore-0.13.7.tar.gz 64734 BLAKE2B e6c4b1720ce4bf62689995d3e1c648c4702bb416f3b3586eb8dd2f0cfd2155046e64181c4c04e65f721a5f0fcbc23b5ffd01c2930c7c69d37ee4c36e37b7d0d4 SHA512 0cc48828d0710066b3ef89998ec85975285763ac63a8b59106952ef2dac5a02dac71e7e106c4b6ea1022eb4d06a9cb5ee3e634eb564bad49c5508beff75279d6
diff --git a/dev-python/httpcore/httpcore-0.13.3.ebuild b/dev-python/httpcore/httpcore-0.13.3.ebuild
deleted file mode 100644
index 23125e851e56..000000000000
--- a/dev-python/httpcore/httpcore-0.13.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A minimal low-level HTTP client"
-HOMEPAGE="https://www.encode.io/httpcore/"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
-
-RDEPEND="
- <dev-python/h11-0.13[${PYTHON_USEDEP}]
- <dev-python/h2-5[${PYTHON_USEDEP}]
- =dev-python/sniffio-1*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # anyio and trio are not in the tree
- sed -i 's/^@pytest.mark.\(anyio\|trio\)/@pytest.mark.skip/' \
- tests/async_tests/test_*.py || die
- sed -i '/^import trio/d' tests/utils.py || die
- # pproxy is not in the tree, the associated fixture
- # must be disabled to prevent errors during test setup
- sed -i 's/def proxy_server().*/&\n pytest.skip()/' \
- tests/conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local skipped_tests=(
- # Require Internet access or hypercorn (not in the tree)
- tests/test_threadsafety.py::test_threadsafe_basic
- tests/sync_tests/test_interfaces.py::test_http_request
- tests/sync_tests/test_interfaces.py::test_https_request
- tests/sync_tests/test_interfaces.py::test_http2_request
- tests/sync_tests/test_interfaces.py::test_closing_http_request
- tests/sync_tests/test_interfaces.py::test_connection_pool_get_connection_info
- tests/sync_tests/test_interfaces.py::test_max_keepalive_connections_handled_correctly
- tests/sync_tests/test_interfaces.py::test_explicit_backend_name
- tests/sync_tests/test_interfaces.py::test_connection_timeout_tcp
- tests/sync_tests/test_interfaces.py::test_broken_socket_detection_many_open_files
- tests/sync_tests/test_retries.py::test_no_retries
- tests/sync_tests/test_retries.py::test_retries_exceeded
- tests/sync_tests/test_retries.py::test_retries_enabled
- # Require hypercorn
- tests/sync_tests/test_interfaces.py::test_connection_timeout_uds
- )
- epytest ${skipped_tests[@]/#/--deselect }
-}
diff --git a/dev-python/httpcore/httpcore-0.13.6.ebuild b/dev-python/httpcore/httpcore-0.13.6.ebuild
deleted file mode 100644
index de418b61e2df..000000000000
--- a/dev-python/httpcore/httpcore-0.13.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A minimal low-level HTTP client"
-HOMEPAGE="https://www.encode.io/httpcore/"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ~ppc64 sparc x86"
-
-RDEPEND="
- =dev-python/anyio-3*[${PYTHON_USEDEP}]
- <dev-python/h11-0.13[${PYTHON_USEDEP}]
- <dev-python/h2-5[${PYTHON_USEDEP}]
- =dev-python/sniffio-1*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # trio is not in the tree, anyio is causing tons of test failures
- # (probably insisting on using trio)
- sed -i 's/^@pytest.mark.\(anyio\|trio\)/@pytest.mark.skip/' \
- tests/async_tests/test_*.py || die
- sed -i '/^import trio/d' tests/utils.py || die
- # pproxy is not in the tree, the associated fixture
- # must be disabled to prevent errors during test setup
- sed -i 's/def proxy_server().*/&\n pytest.skip()/' \
- tests/conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local skipped_tests=(
- # Require Internet access or hypercorn (not in the tree)
- tests/test_threadsafety.py::test_threadsafe_basic
- tests/sync_tests/test_interfaces.py::test_http_request
- tests/sync_tests/test_interfaces.py::test_https_request
- tests/sync_tests/test_interfaces.py::test_http2_request
- tests/sync_tests/test_interfaces.py::test_closing_http_request
- tests/sync_tests/test_interfaces.py::test_connection_pool_get_connection_info
- tests/sync_tests/test_interfaces.py::test_max_keepalive_connections_handled_correctly
- tests/sync_tests/test_interfaces.py::test_explicit_backend_name
- tests/sync_tests/test_interfaces.py::test_connection_timeout_tcp
- tests/sync_tests/test_interfaces.py::test_broken_socket_detection_many_open_files
- tests/sync_tests/test_retries.py::test_no_retries
- tests/sync_tests/test_retries.py::test_retries_exceeded
- tests/sync_tests/test_retries.py::test_retries_enabled
- # Require hypercorn
- tests/sync_tests/test_interfaces.py::test_connection_timeout_uds
- )
- epytest ${skipped_tests[@]/#/--deselect }
-}