summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 09:11:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 09:11:59 +0200
commitda705ae46bbff74657bb594a95d1b28067f84041 (patch)
treea1adc0f6303b725832920691eed5c008ce2cd828 /dev-python/hatchling
parentdev-python/editables: Remove old (diff)
downloadgentoo-da705ae46bbff74657bb594a95d1b28067f84041.tar.gz
gentoo-da705ae46bbff74657bb594a95d1b28067f84041.tar.bz2
gentoo-da705ae46bbff74657bb594a95d1b28067f84041.zip
dev-python/hatchling: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest2
-rw-r--r--dev-python/hatchling/hatchling-0.22.0.ebuild72
-rw-r--r--dev-python/hatchling/hatchling-0.23.0.ebuild72
3 files changed, 0 insertions, 146 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 45c29c86b663..18eeac7c5bc1 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -1,3 +1 @@
-DIST hatch-hatchling-v0.22.0.tar.gz 201590 BLAKE2B c75e48a19e10f04d9bb1d09beea0ec6598bded5dc9e595f363a076731b7708bae55169ee780931b548478c16db093053c65e30a5510f7b0136c1d339caf29d39 SHA512 cc532b66752d0494b62fb4ed88c8b7870d5618c991b301f46b644aa90b656cfe842efd2fa96797a6b96015deb3468ff8ff69058bd146133360de340d367a5489
-DIST hatch-hatchling-v0.23.0.tar.gz 212046 BLAKE2B 8cc73c68bc476cd282686dc69314fd401f5aac4d5d5df083a338aaf59125988aabc9d33f97ad556013d46886d43facef92e7951e7b0a7bc3fc1ab608a16fca11 SHA512 0666b95e68fcd6fbcdeda5fdce577a1178ca8a965226c58495cfc2699bac2aabe3f3bc162e8bb5b03c9c70ff7aa678be6aba5c343dd787600d2f5ee883685444
DIST hatch-hatchling-v0.24.0.tar.gz 212154 BLAKE2B fc0fcdd20eb1a1040298a4c959911d291ca454cf82404b0a7a67a9d192e3af0b8ee5a50d169e803bd5602775cf3f9336fd56d83c6fa85aa8d9f805269205ed29 SHA512 f4a1764f129c6e3098d0b0c744dca4f0b499c43d53dcebffc7aa26e28e3f599a9370e0f1f8ee9b9130042f066e1c857e155ffbdcf86d2c18e32ff5bc9219c51e
diff --git a/dev-python/hatchling/hatchling-0.22.0.ebuild b/dev-python/hatchling/hatchling-0.22.0.ebuild
deleted file mode 100644
index 74fbe0e7a565..000000000000
--- a/dev-python/hatchling/hatchling-0.22.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-TAG=${P/-/-v}
-MY_P=hatch-${TAG}
-DESCRIPTION="Modern, extensible Python build backend"
-HOMEPAGE="
- https://pypi.org/project/hatchling/
- https://github.com/ofek/hatch/
-"
-SRC_URI="
- https://github.com/ofek/hatch/archive/${TAG}.tar.gz
- -> ${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}/backend
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~m68k ~ppc ~riscv ~s390 ~sparc"
-
-RDEPEND="
- >=dev-python/editables-0.2[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.9[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # TODO: remove this when gpep517 is the norm
- local -x PYTHONPATH=src
- distutils-r1_python_compile
-}
-
-python_test() {
- local -x EPYTEST_DESELECT=(
- # these run pip to install stuff
- tests/backend/dep/test_core.py::test_dependency_found
- tests/backend/dep/test_core.py::test_extra_met
- tests/backend/dep/test_core.py::test_extra_no_dependencies
- tests/backend/dep/test_core.py::test_extra_unmet
- tests/backend/dep/test_core.py::test_unknown_extra
- tests/backend/dep/test_core.py::test_version_unmet
- )
-
- # top-level "tests" directory contains tests both for hatch
- # and hatchling
- cd "${WORKDIR}/${MY_P}" || die
- local -x PYTHONPATH="src:${PYTHONPATH}"
- epytest tests/backend
-}
diff --git a/dev-python/hatchling/hatchling-0.23.0.ebuild b/dev-python/hatchling/hatchling-0.23.0.ebuild
deleted file mode 100644
index 74fbe0e7a565..000000000000
--- a/dev-python/hatchling/hatchling-0.23.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-TAG=${P/-/-v}
-MY_P=hatch-${TAG}
-DESCRIPTION="Modern, extensible Python build backend"
-HOMEPAGE="
- https://pypi.org/project/hatchling/
- https://github.com/ofek/hatch/
-"
-SRC_URI="
- https://github.com/ofek/hatch/archive/${TAG}.tar.gz
- -> ${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}/backend
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~m68k ~ppc ~riscv ~s390 ~sparc"
-
-RDEPEND="
- >=dev-python/editables-0.2[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.9[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- # TODO: remove this when gpep517 is the norm
- local -x PYTHONPATH=src
- distutils-r1_python_compile
-}
-
-python_test() {
- local -x EPYTEST_DESELECT=(
- # these run pip to install stuff
- tests/backend/dep/test_core.py::test_dependency_found
- tests/backend/dep/test_core.py::test_extra_met
- tests/backend/dep/test_core.py::test_extra_no_dependencies
- tests/backend/dep/test_core.py::test_extra_unmet
- tests/backend/dep/test_core.py::test_unknown_extra
- tests/backend/dep/test_core.py::test_version_unmet
- )
-
- # top-level "tests" directory contains tests both for hatch
- # and hatchling
- cd "${WORKDIR}/${MY_P}" || die
- local -x PYTHONPATH="src:${PYTHONPATH}"
- epytest tests/backend
-}