summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-16 08:48:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-16 09:55:55 +0200
commit3443204741525b417f0881e67e0a338a4212af17 (patch)
tree8bf4171aa6c708c57609baf621cc622c20d68239 /dev-python/hatchling
parentdev-python/imageio: Bump to 2.19.2 (diff)
downloadgentoo-3443204741525b417f0881e67e0a338a4212af17.tar.gz
gentoo-3443204741525b417f0881e67e0a338a4212af17.tar.bz2
gentoo-3443204741525b417f0881e67e0a338a4212af17.zip
dev-python/hatchling: Bump to 0.25.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest1
-rw-r--r--dev-python/hatchling/hatchling-0.25.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 18eeac7c5bc1..19b4bb7f7323 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -1 +1,2 @@
DIST hatch-hatchling-v0.24.0.tar.gz 212154 BLAKE2B fc0fcdd20eb1a1040298a4c959911d291ca454cf82404b0a7a67a9d192e3af0b8ee5a50d169e803bd5602775cf3f9336fd56d83c6fa85aa8d9f805269205ed29 SHA512 f4a1764f129c6e3098d0b0c744dca4f0b499c43d53dcebffc7aa26e28e3f599a9370e0f1f8ee9b9130042f066e1c857e155ffbdcf86d2c18e32ff5bc9219c51e
+DIST hatch-hatchling-v0.25.0.tar.gz 216944 BLAKE2B 298f284bc05bbba6c463d4c22ddbbd1438a3a068de2a14300343803f706f2bc3a69be83bdbb1876f4f2474e7cb1ac4e98226108ad290c5097bbc1135367b7183 SHA512 1cfc8ea27e46e316efeeee321e17770995e495f0b6a722b89d9632af7902e3a7ee7c5a729b8ca27e490a94b7ddcda9b4e03dd7274b305f928b0e31a469a1643f
diff --git a/dev-python/hatchling/hatchling-0.25.0.ebuild b/dev-python/hatchling/hatchling-0.25.0.ebuild
new file mode 100644
index 000000000000..c768e17f0e8e
--- /dev/null
+++ b/dev-python/hatchling/hatchling-0.25.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/pypa/hatch/
+"
+SRC_URI="
+ https://github.com/pypa/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/editables-0.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ ' pypy3 python3_{8..10} # TODO: 3.11 when deps are ported
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON}" pypy3 python3.{8..10}; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x EPYTEST_DESELECT=(
+ # these run pip to install stuff
+ tests/backend/dep/test_core.py::test_dependency_found
+ tests/backend/dep/test_core.py::test_extra_met
+ tests/backend/dep/test_core.py::test_extra_no_dependencies
+ tests/backend/dep/test_core.py::test_extra_unmet
+ tests/backend/dep/test_core.py::test_unknown_extra
+ tests/backend/dep/test_core.py::test_version_unmet
+ )
+
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+ epytest tests/backend
+}